This tag is reserved for questions where the problem has been vetted by this community and the observed behavior is confirmed to be a bug. Please do not use this tag for new questions. Please use the standard bugs header instead of version tags in conjunction with this tag.

learn more… | top users | synonyms (1)

5
votes
0answers
140 views

RegionPlot, RegionPlot3D and differing embedding dimensions

RegionPlot seems to be for plotting regions with an embedding dimensions of 2 only, and RegionPlot3D for regions with an ...
11
votes
1answer
119 views

IsomorphicGraphQ fails to recognize that two empty graphs are identical

Bug introduced in 9.0.1 or earlier and persisting through 10.3.0 Consider the following two graphs: ...
10
votes
2answers
137 views

Possible Bug in Computing Surface Area of Certain Geometric Regions

Mathematica 10.2 introduced some new geometric regions. Two of the new regions include SphericalShell and CapsuleShape. ...
11
votes
1answer
109 views

Problem with Clear[assoc] as a value in an Association

Bug introduced in 10.1 or earlier and fixed in 10.3 According to the documentation, in order to make sure that a value in an association is not evaluated at initialization, one can use a ...
10
votes
1answer
126 views

Odd StringTake problem in Dataset

10.2 Win64 Works fine... Dataset[{<|"a"->"ABC"|>}][All, StringTake[#a,{1,3}]&] Explicitly taking the whole string using its length directly. ...
4
votes
0answers
82 views

TimelinePlot with Interval in Associations

Bug introduced in 10.2 This is related to a previous question I asked about TimelinePlot and multiple associations (Behavior of TimelinePlot with multiple ...
0
votes
1answer
87 views

Loss of chart when exporting data in DynamicModule

Bug fixed in V 10.2 In DynamicModule, the result is to show a panel with a flowchart and a Piechart. But when I export the ...
6
votes
0answers
101 views

Possible Bug with Options in DelaunayMesh

Update: It turns out after some testing, none of the Options work in DelaunayMesh when 3D point sets are involved. Original ...
2
votes
2answers
153 views

SeriesCoefficients expansion contradicts FullSimplify

Executing the following SeriesCoefficient[Log[1/2 (1 + Sqrt[1 - x])], {x, 0, n}, Assumptions -> {n >= 1, n ∈ Integers}] I get: which clearly asserts ...
13
votes
1answer
258 views

Streaming`LazyList`Testing may have a leak

Bug introduced in 10.2 and fixed in 10.3 Version 10.2; Win64 Enterprise. I'm seeing this message... data::shdw: Symbol data appears in multiple contexts {Streaming`LazyList`Testing`, Global`}; ...
3
votes
1answer
136 views

Export in Mathematica 9 vs Mathematica 10

Bug introduced in 10.0 and fixed in 10.0.2 I want to export a list of complex numbers as follows: ...
18
votes
2answers
354 views

10.2 Dataset extraneous print using Transpose

Bug introduced in 10.2 and fixed in 10.2 (by paclet update GeneralUtilities 10.2.1) This is probably patch code in 10.2. Is there a way to turn off print with ...
5
votes
1answer
126 views

memory leaks using NIntegrate on parallel kernel

Bug fixed in version 10.2.0 I'm running a large computation in parallel and the memory usage of the parallel kernels is increasing with every iteration of the calculation. Neither ...
20
votes
2answers
394 views

Getting rid of spikes in the PDE solution

Bug introduced in 10.0 and fixed in 10.3 Note: In 10.0, Rationalize[fd, 0] was needed or mesh generation would fail. Preamble: I am solving a PDE in a domain ...
9
votes
1answer
122 views

Union on Associations (Kernel Kill)

Bug introduced in 10.1 and fixed in 10.2.0 Perhaps Union on Associations is not being encouraged since ...
17
votes
1answer
294 views

Simple Matrix multiplication takes very long

Bug introduced in 10.1.0 and fixed in 10.3.0 I came across some strange behaviour during a computation involving matrices with symbolic values. It is reproduced below. Multiplying a random 30x30 ...
8
votes
2answers
158 views

Mesh Problems with MatrixPlot

I've come across some weird behavior in 10.1 when trying to use Mesh with MatrixPlot. In the example below, when specifying Mesh, I only get one line along the X axis at 100 instead of lines at {100, ...
10
votes
1answer
273 views

Dirichlet coefficients as limits: wrong

Perhaps I should have included the word "bug" in my question. Here we go There is a bug in this Limit Limit[3^s (-1 - 2^-s + Zeta[s]), s -> ∞] (* 0 *) which ...
5
votes
1answer
119 views

RegionIntersection fails for some values with polygons

Bug introduced in 10.1 and fixed in 10.3.0 I want to find the intersection (region) of 2 polygons. I use RegionInstersection but it only works for some sizes, ...
9
votes
0answers
90 views

Strange result of DeleteCases in an association

The function DeleteCases can be used for associations, also with level specification. Here is an example where some values are associations: ...
14
votes
1answer
268 views

What's wrong with Simplify and FullSimplify?

I have a quite complex list of equations and inequalities I combine to a boundary condition for my cost function. After investigation of two days I found the bug (I really name it a bug!). One of my ...
4
votes
1answer
258 views

Why don't the arrowheads show for this directed graph?

Bug introduced in version 9.0 or earlier and fixed in 10.3 It's very weird, but the first graph is shown as undirected (dots connected by lines, not arrows. The second is shown as directed, with ...
1
vote
1answer
114 views

Undo (CTRL Z as well as under edit) bug after pressing control shift [duplicate]

Bug introduced in 10.0 and fixed in 10.0.2 As some of you might know, if you press control + shift on windows, you change your keyboard layout. For example, : becomes ±. This happens sometimes in ...
6
votes
1answer
239 views

Manipulate code crashes V10.1

This code is working with Mathematica 9, but Mathematica 10.1 is becomes unresponsive when I try to evaluate it. ...
5
votes
2answers
101 views

ParametricNDSolveValue has a problem with complex numbers

Bug introduced in version 10 and fixed in 10.3 Edited: I have simplified the example compared to before and narrowed the problem down a bit. I would like to use ...
12
votes
1answer
207 views

Using Simplify on a consistent system returns False

Bug introduced in 8.0 and fixed in 10.3. It's late, but am I missing something here? Why should two independent equations, which together are consistent, ...
4
votes
1answer
121 views

DateListPlot in webMathematica doesn't show FrameTicks properly

It seems that DateListPlot when used in webMathematica (3.3.1) show different output than in desktop Mathematica (10.1). In desktop Mathematica, if you evalutate ...
15
votes
2answers
312 views

Exporting Dataset to WDX format fails

I reported this to WRI support. Tracking number is CASE:3368636 Official answer is: Thank you for contacting Wolfram Technical Support. This is a known issue and our developers are working on a ...
13
votes
0answers
89 views

Floating highlighting bug [duplicate]

Bug introduced in 10.0 and not fixed up to 10.2 At some random point in time the highlighting does not disappear any more. By highlighting I mean transparent boxes appearing for find feature ...
7
votes
1answer
184 views

Trouble with polynomial multiplication

Bug introduced in 10.1.0 and persisting through 10.3.0 or later ...
6
votes
2answers
201 views

ToElementMesh problem on Ball defined by ImplicitRegion?

Bug introduced in 10.0 and fixed in 10.2 Could any one please confirm the following bug in mathematica 10.0.2 ? If I define this ball ...
3
votes
0answers
96 views

Transparent bitmaps in controllers. Problem with initial appearance

Bug introduced in V9.0 or earlier and persisting through 10.3.1 or later I have a problem with images with alpha channel which I want to use as labels on Button ...
3
votes
1answer
101 views

ConvexHullMesh sometimes excludes valid points from convex hull

I have a sequence of polytopes that I am trying to visualize, and I find that ConvexHullMesh sometimes excludes points from the convex hull, and it does so inconsistently. In particular, notice these ...
2
votes
2answers
236 views

Solving coupled first-order autonomous differential equations

I am trying to run a simulation of a circuit to observe chaotic behavior, and have obtained a set of differential equations from an analysis of the circuit. I thought perhaps I could produce a plot ...
9
votes
1answer
148 views

Kernel Crash while using “ValuesOnGrid” method of InterpolatingFunction

Bug introduced in 10.0.0 and fixed in 10.2.0 I was experiencing some kernel crash while using "ValuesOnGrid" method of an ...
9
votes
1answer
174 views

Comparing exact expressions for equality — is it really OK if I get wrong answer?

Bug introduced in 7.0 or earlier and fixed in 10.2.0 I found an unexpected behavior (that I think of as a bug) in evaluation of the equality operator applied to mathematical functions with exact ...
7
votes
1answer
205 views

How to make sure polygon is drawn flat in 3D?

Bug introduced in 8.0 or earlier and persisting through 10.2 or later I'm working on this SE question about pentagrams on top of dodecahedron for exercising. Both solutions are basically connecting ...
16
votes
2answers
427 views

Error “Throw::nocatch: Uncaught Throw[False] returned to top level” given each time I open a new Mathematica 10.1 session

Bug fixed in 10.1.0 via paclet update From a few days now each time I open a new Mathematica session I get the small error messages window with the error ...
5
votes
1answer
129 views

Unknown (internal?) function with `DSolve`

Bug introduced in 8.0 or earlier and fixed in 10.3.0 I am solving With Mathematica 10 the following ODE system: ...
2
votes
0answers
79 views

Alt drag does not work properly

When a graphics is displayed, right clicking will bring up the Get Coordinates tool. To select a rectangular region, you can do it manually by selecting the two corners and Alt+C will copy these two ...
6
votes
3answers
217 views

Problem About TimelinePlot

Bug introduced in 10.1 and fixed in 10.3 TimeLinePlot was introduced in 10.1 I have some data from wikipedia. ...
5
votes
1answer
106 views

Why does the degree symbol disrupt this FrameLabel?

This plot Plot[x, {x, 0, 1}, FrameLabel -> {"x", "temperature / \[Degree]C"}, Frame -> True] displays beautifully, but exporting to PDF ...
6
votes
0answers
62 views

VertexDelete not working on graph with VertexWeight

Bug introduced in 10.0 and fixed in 10.3 Good afternoon, I have observed an "unexpected behaviour" with VertexDelete and a graph with vertex weights. This is a minimal working example: OK ...
7
votes
2answers
209 views

Transpose can't handle fractions

Bug introduced in 10.0 and fixed in 10.2.0 Note: Dataset and Association are new in 10.0 Related to this question, why can't ...
1
vote
1answer
102 views

Switching to CloudObject`Private`

I shut Mathematica done, then restart it. The image shows all that I do. I have done nothing else. Can anyone explain what is happening to me? The complete code is: ...
19
votes
4answers
904 views

A bug in Integrate

Integrate[(1 + 16 Tan[2 x - y]^2)/(1 + 4 Tan[2 x - y]^2), {x, 0, 2 π}] Mathematica (wrong) output is (tested under versions 8 and 10.0, took ~ 1 minute of CPU ...
5
votes
1answer
212 views

Wrong Limit in Mathematica 10.0.0

Bug introduced in 9.0.0 and fixed in 10.0.1 Limit[(Log[(3+Sqrt[5])/2]/(2*Log[(1+Sqrt[5])/2]))^(-1-2*n), n -> Infinity] Mathematica (wrong) output: ...
9
votes
1answer
190 views

Wrong Limit with LaguerreL

Bug introduced in 7.0 and fixed in 10.2.0 Limit[(n! LaguerreL[n,-1]/(n^(n+1/4)/Sqrt[2]/E^(n-2 Sqrt[n]+1/2))-1) Sqrt[n], n->∞] Mathematica (wrong) output ...
8
votes
1answer
144 views

LogisticSigmoid residue bug?

Bug introduced in 10.0 and fixed in 10.2.0 On version 10.0 for arm: Residue[LogisticSigmoid[z],{z,I Pi}] gives 0 not 1. ...