This tag is reserved for questions where the problem has been vetted by this community and the observed behavior is confirmed to be a bug. Please do not use this tag for new questions. Please use the standard bugs header instead of version tags in conjunction with this tag.

learn more… | top users | synonyms (1)

5
votes
4answers
158 views

How do I emulate DiscreteUniformDistribution in Mathematica?

How do I define a function from scratch that emulates DiscreteUniformDistribution? As shown below, attempting to use ...
15
votes
5answers
566 views

BSplineFunction derivatives wrong if using weights?

Bug introduced in 7.0 and persisting through 10.4 In my work, I make heavy use of non-uniform rational B-spline (NURBS) functions, defined using the function ...
2
votes
2answers
525 views

EdgeRenderingFunction question

Bug introduced in 9.0 and fixed in 10.0.0 (Edit 1 : I added this paragraph after the original post, for context) Some context for this question can be found in another post ...
10
votes
1answer
379 views

Mathematica9: NDSolve slows down after repeated calls

I have noted that in Mathematica 9 my code, which involves a lot of calls to NDSolve, slows down considerably after some time. Apparently, the problem is NDSolve itself and it seems to be related to ...
8
votes
1answer
588 views

Why does Simplify with TimeConstraint return Removed[$$Failure]?

Bug introduced in 7.0 or earlier and fixed in 10.0.0 I have a rather ugly Mathematica expression (edit: shown below) that I would like to simplify with a time constraint; simplifying without a time ...
36
votes
2answers
1k views

eigenvector bug?

Bug introduced in 7.0.1 or earlier and fixed in 10.0.0 I have a fairly simple $3\times3$ complex matrix, $$ M=\left( \begin{array}{ccc} \frac{7}{2}-\frac{i}{2} & -1+i & \frac{1}{2}+\frac{5 ...
20
votes
1answer
230 views

How to format usage messages such that function templates are parsed correctly?

Is it possible to format usage messages (with italic arguments etc) such that Mathematica 9 still parses function templates correctly? For example, plain usage messages work when pressing ...
2
votes
0answers
281 views

Positive integrand giving negative answer

I'm integrating a positive function f(t) times sin(t) from 0 to pi/5 and get -38. Actually f is slightly negative for a short time (smallest value ~ -0.0005), but far from enough to explain this. ...
6
votes
3answers
826 views

ListPolarPlot not showing full plot range even with PlotRange -> All

I have a list of data dpdOt (given below) with associated angular coordinates thetaplot, which when plotted using ...
11
votes
1answer
242 views

LibraryLink Documentation

Bug fixed in version 10.0.0 The documentation for LibraryLink has the following example ...
3
votes
0answers
103 views

Det and MatrixRank freezes on SparseArray with nonzero default value

Bug introduced in 7.0 or earlier and fixed in 9.0.1 or earlier Why does the following simple code never come to an end (at least with version 8) ...
3
votes
0answers
342 views

Weird behaviour from ListSurfacePlot3D

Looking at Documentation for ListSurfacePlot3D, I follow the basic example presented there. ...
13
votes
2answers
417 views

PlotRangeClipping not working correctly with small ImageSize and PDF-export

Bug introduced in 8 or earlier and persists through 10.4 or later Although Mathematica has some nice plotting capabilities, there are some things which are annoying me: I like to export a Graphics ...
4
votes
0answers
105 views

2X slower with ; — LibraryLink performance problem [duplicate]

This is the continued problem of the LibraryLink memory usage question here and here. In the following code, there is a 2X performance difference with only the change of ";". ...
11
votes
1answer
284 views

Where is my memory? — LibraryLink never returns the memory

Bug introduced in 8.0 or earlier and persisting through 10.3 This is an example LibaryLink code from Mathematica documentation, which takes an integer and return an integer list: ...
19
votes
2answers
576 views

Have I found a bug in Integrate?

The following command gives 0 in Mathematica 9.0.1. ...
2
votes
1answer
162 views

Spelling dictionary corrupted

Bug introduced in 9.0 and fixed in 9.0.1 I have a problem with the Check Spelling in Mathematica, that I quite don't understand: If I try to use the Check Spelling on any notebook, the check just ...
8
votes
1answer
328 views

Error while exporting to Excel with named sheets

Using Mathematica v9.0.1 This example is from the docs: ...
3
votes
1answer
206 views

Exporting large png results in completely black image

When trying to export an Image as PNG the resulting file is a completely black image. This happens only for certain images I have not been able to determine exactly ...
10
votes
2answers
394 views

Why LibraryLink function crashes at a second time?

Bug introduced in 9.0 or earlier and fixed in 10.3 Update As Todd Gayley commented under halirutan's answer, this is a bug. I'm trying link one of Lapack's function to Mathematica through ...
23
votes
1answer
507 views

Why does list assignment with a packed array result in unpacked values?

Bug introduced in 5.2 or earlier and fixed in 10.1.0 This is another question on the design choices in Mathematica. I understand that without direct reply from the developers it may not be ...
8
votes
1answer
674 views

Importing Excel Spreadsheet containing Array Formulas

Has anyone had any success with importing an Excel Spreadsheet holding an array formula into Mathematica? The Syntax I'm using is ...
5
votes
1answer
262 views

Error messages from compiling the Piecewise function

The following works Compile[{{x, _Real}}, Piecewise[{{{0., 0.}, x > 5.}}, {1., 1.}]] but if I enter the Piecewise[...] in ...
9
votes
3answers
409 views

PlotMarkers don't change colour for different lines

I have a set of data and several function operating on the same data, that I wish to plot together in a ListPlot. I need different ...
12
votes
1answer
307 views

Why is my rasterized graphic blank?

Bug introduced in 7.0 or earlier, and persisting through 10.1 or later (OSX 10.10.2) Consider the following code: ...
6
votes
1answer
199 views

Error in ARIMAProcess example

I am trying to compile the sample of ARIMAProcess of MMA here .It doesn't work.What is wrong?Could you please help?I am using exact same code. ...
13
votes
2answers
569 views

How to embed an image into a string?

Note: The bug described in the post is in Mathematica 9, and has been fixed in 10.0. The documentation for String contains the following statements: Strings ...
11
votes
1answer
576 views

RLink and R v3.0.1?

Running InstallR["RHomeLocation" -> "C:\\Program Files\\R\\R-3.0.1"] results in a popup box titled "Version Mismatch" saying Error: R.DLL version does ...
5
votes
1answer
261 views

Exporting multiple arrays in a single HDF5 file in Mathematica 7

Bug introduced in 7.0 and fixed in 8.0 I am using Mathematica 7 and I need to export a table of data and the corresponding x and ...
4
votes
1answer
637 views

InverseFunction on an Interpolating Function is misbehaving

I am getting strange behavior when I try to calculate the inverse of an interpolating function for two similar data sets. My data sets are: ...
8
votes
1answer
523 views

Mathematica 9 can't integrate this function but earlier versions could

Integrate[ ArcTan[x]/(1 + x) Log[(1 + x^2)/2], {x, -1, 1}] I used Mathematica 9.0.1 on Windows7 32bit, Mathematica 9 cannot compute this, but Mathematica 8 gives ...
13
votes
2answers
641 views

Problem importing URL with Greek characters

I'm considering buying a car. So I thought why not make a web-crawler in Mathematica to pile-up car data? Brilliant idea. Then I found this Greek website, gocar.gr, which just so happens to have all ...
7
votes
1answer
323 views

Exporting large numbers in WDX format

Bug introduced in 9.0 and fixed in 10.3 I have a list of 10 000 3×3 matrices in Mathematica. The entries are rational numbers. I would like to write this to a file so I can load it again in the ...
21
votes
3answers
936 views

How accurate is GeoDistance?

Two years ago I tried an evaluation copy of Mathematica. I reported various inaccuracies in the GeoDistance routine to which I never received any fix. Could ...
8
votes
1answer
315 views

Mathematica8 can compile this function but Mathematica 9 can't if I set CompilationTarget -> “C”

Following code worked on Mathematica 8, but in Mathematica 9 it can't be compiled, it return this message CompiledFunction::cflist: Nontensor object generated; proceeding with uncompiled ...
1
vote
0answers
243 views

Frame and white background not working (all other colours are fine)

Bug introduced in 6 and fixed in 7 Though my question my be related to this one, it doesn't look like it can easily be solved in the same way, so I hope not to be double-posting. I am trying to ...
2
votes
0answers
329 views

Why my Mathematica 9.0.1 wont work with some samples of Mathematica in Graph Theory?

Bug introduced in 9.0 and fixed in 10.0 FindMinimumCostFlow is introduced in 9.0. I updated my Mathematica recently to 9.0.1 cause the previous version was ...
10
votes
3answers
434 views

Why is this parallel evaluation with Dispatch[] so slow?

Can you efficiently parallelize this? The parallel versions are much slower than the sequential version, and I'm not sure why. Does SetSharedVariable allow ...
36
votes
2answers
1k views

Variable naming changes everything

Bug fixed in 10.0.0 I am having a rather unusual problem I do not understand with Mathematica where renaming one of the variables of my function causes the function to stop "working". Here is the ...
6
votes
1answer
299 views

Importing images from the web using ImportString & URLFetch

I can bring images from the web using the Import command like this: Import["http://blog.wolfram.com/wp-content/uploads/2008/06/se-30.jpg"] Sometimes the web ...
19
votes
0answers
259 views

Compile not correctly initializing a variable defined inside Module

Bug introduced in 8.0 and persisting through 10.3.1 or later In the following example, inside the minimumX's Module, ...
5
votes
2answers
155 views

RSolve gives a Context::ssle error

Bug introduced in 9.0 or earlier and fixed in 10.0 I want to solve the following recurrence equation RSolve[{(k + 2) c[k + 2] q^(k + 1) - c[k] == 0}, c[k], k] ...
5
votes
1answer
154 views
12
votes
2answers
817 views

Why can't I change the value of MaxRecursion in NIntegrate when integrating BesselJ?

Bug introduced in 8.0.4 or earlier and persists through 10.4. I am trying to evaluate this integral numerically $$ \int_0^{\infty } J_0(q R) \tanh(q) \, \mathrm{d}q $$ for large values of $R$. ...
5
votes
1answer
230 views

Error invoking Information on functions containing Legended

In adapting some plotting functions to utilize the PlotLegends option of version 9, I came across the following errors: ...
4
votes
2answers
151 views

Strange behavior of Integrate

I'm trying to calculate the following integral using Mathematica 9.0.1.0 a11=Integrate[Abs[Sin[b+x]],{x,0,2*\[Pi]}] This should be a simple problem; however, it ...
11
votes
1answer
487 views

FourierSeries for rational function looks wrong

I have the following code: ser[x_] = FourierSeries[(\[Pi]^2 + a)/(3 x^2 + a), x, 10] // N // Chop It gives me some series, which I then try to plot. And ...
2
votes
1answer
406 views

Derivatives of list elements

Bug introduced in 8.0.0 and fixed in 9.0.0 Could someone explain the odd behavior of the Derivative function when drawing arguments from lists? We have, ...
7
votes
1answer
177 views

Compiled function crashes kernel when trying to list over different length arguments

Bug introduced in 8.0 and fixed in 10.0 I'm trying to speed up a tally/binning operation that I have to run many times. I have many lists of between 1 and 10 numbers from the range [1,5] and I ...
7
votes
2answers
364 views

Problem with NIntegrate when WorkingPrecision is specified

I am trying to evaluate this integral numerically: $$ \int_0^{\infty } m \exp (-m) J_1(m){}^2 \, dm $$ Everything is OK when only the integration method is specified: ...