Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I've learned how to use this shortcut to input fractions in the 2D form, it worked nice on my notebook but I can't make it on my desktop. Any tip on what could be happening?

share|improve this question
    
Have you checked the default IME? –  xzczd Aug 13 '12 at 10:37
1  
What does "can´t make it on my desktop" mean? –  Yves Klett Aug 13 '12 at 10:53
2  
Please be more specific about both platforms (OS, language settings, keyboard, MMA version). –  Sjoerd C. de Vries Aug 13 '12 at 11:09
    
@YvesKlett In my keyboard, the / is sometimes behind a baguette –  belisarius Aug 13 '12 at 12:07
    
@YvesKlett It's a computer running Windows Seven 64Bits. My keyboard is brazilian portuguese. Any more details? –  Igäria Mnagarka Aug 14 '12 at 5:09
show 1 more comment

1 Answer

up vote 4 down vote accepted

You are not very specific in your details so I have to guess what may be wrong. I can come up with some possibilities:

Keyboard shortcuts redefined
Keyboard shortcuts are defined in the file KeyEventTranslations.tr. This is located in the directory specified by executing either

FileNameJoin[{$InstallationDirectory, "SystemFiles", "FrontEnd", "TextResources", 
              $OperatingSystem}]

or

FileNameJoin[{$UserBaseDirectory, "SystemFiles", "FrontEnd", "TextResources", $OperatingSystem}]

Shortcut definitions in file in the latter directory (if present) override definitions in in the former.

Search for a line that looks like

Item[KeyEvent["/", Modifiers -> {Control}], "Fraction"],

which defines the fraction shortcut. Check whether this contains the "/" character (default) or something different.

Numeric keypad used
Perhaps you normally use the "/" on the numeric keypad of your desktop. For this key to work the Numlock key needs to be set to the correct state.

OS keyboard setting
Perhaps the keyboard setting of your OS tells your programs that different keys are pressed than what's printed on the key. For instance, if I set the keyboard type of my (physical) US international keyboard to French, pressing the 'q' key gets me an 'a'. You probably have a Brazilian keyboard which is rather unusual. Some versions of Ubuntu seem to have problems with that. My keyboard generates a ";" instead of a "/" when Windows is told it's Brazilian.

share|improve this answer
    
Oh, I've added some aditional details: It's a computer running Windows Seven 64Bits. My keyboard is brazilian portuguese. –  Igäria Mnagarka Aug 14 '12 at 5:14
    
It worked with the numpad's /. Thanks –  Igäria Mnagarka Aug 14 '12 at 5:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.