Mathematica Stack Exchange is a question and answer site for users of Mathematica. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Mathematica 8, whenever I enter "hello" into a cell of style "text", the quote marks are automatically converted to special characters:


This automatic substitution does not happen in a cell of style "input" (good!).

Because I use Mathematica notebooks as a front-end to LaTeX, for me this substitution is a disaster, no matter where it occurs.

What is the preferred idiom for turning-off this smart-quote feature (and all similar automatic character substitution features) for all cells in a Notebook?

The ASCII characters that I type, are precisely the characters that I want in the notebook!

The Mathematica documentation is unhelpful ... or possibly I am not looking in the correct place.

share|improve this question
up vote 7 down vote accepted

In the Option Inspector (CtrlShift O) look for AutoQuoteCharacters and set this on empty list. I presume you could set the same in the stylefile too.

share|improve this answer
Can also be set in the preferences. – John Sidles Aug 3 '12 at 12:16
@JohnSidles are you going to post that answer. It complements the others so you should. – Mike Honeychurch Aug 3 '12 at 22:06
 Options[EvaluationNotebook[], CommonDefaultFormatTypes]

gives the default formatting:

enter image description here

You can use Options Inspector to change the format type for Text from its default value TextForm to StandardForm:

enter image description here

To change the setting programmatically for the evaluation notebook, you can use:

SetOptions[EvaluationNotebook[], CommonDefaultFormatTypes -> {"Text" -> StandardForm}]


SetOptions[$FrontEnd, CommonDefaultFormatTypes -> {"Text" -> StandardForm}]

changes the setting for all new notebooks.

EDIT: You might want to explore related settings in the Options Inspector:

enter image description here

EDIT 2: I like Sjoerd's answer better. Here is the way to change this option setting programmatically:

SetOptions[EvaluationNotebook[], "AutoQuoteCharacters" -> {}]


SetOptions[$FrontEnd, "AutoQuoteCharacters" -> {}]
share|improve this answer
For me, all cells are "TextForm" (because my notebooks are a front-end for LaTeX). Regrettably Mathematica 8 provides no documentation on this form. :( – John Sidles Aug 3 '12 at 12:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.