Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

Whenever I start Mathematica 8 on my Mac the built-in Mac OS firewall asks if I want to allow JLink to accept incoming connections. Then, during running, I'll get the same question about Mathematica.app. Sometimes the requests occur several times during the day, though not always. It's a minor irritation but it'd be nice to know if there is a way to avoid it while keeping the firewall switched on.

I already have the Mac firewall configured to allow connections permanently for Mathematica.app and JLink.

Thanks

share|improve this question
    
What does this terminal command say for you? codesign -vvv /Applications/Mathematica.app It should say this: /Applications/Mathematica.app: valid on disk /Applications/Mathematica.app: satisfies its Designated Requirement –  cormullion Jul 20 '12 at 14:00
    
It does indeed say that, @cormullion –  Tim Kemp Jul 20 '12 at 15:06
    
Oh well. I read somewhere that it would say something else if it was a code signing issue. –  cormullion Jul 20 '12 at 16:38

1 Answer 1

up vote 6 down vote accepted

I've had this issue for a long time and the only change that "fixed" it is to block all incoming connections. Go to System Preferences > Personal > Security & Privacy > Firewall Options and select Block all incoming connections as shown (you will have to unlock and enter your administrator password):

enter image description here

A less drastic, but possibly riskier option

The reason this occurs has to do with the signature of the app. Sometimes, re-installing the app will fix the problem. If not, an option would be to sign the app yourself. You can read this blog post for directions on how to sign the app yourself. However, do note that if you sign the app, the OS treats it as a very secure app and might be oblivious to other hitherto unknown (possibly malicious) behaviour from the app.

For the aforementioned reasons, I did not choose to go this route. Blocking all incoming connections might seem drastic, but I have not had any issues so far and I can ssh to my computer perfectly fine.

share|improve this answer
    
Thanks. Not sure that will work for me as I have quite a few things in my exceptions list. Will leave this open for a bit in case anyone else has a workaround a bit less drastic! –  Tim Kemp Jul 17 '12 at 21:33
    
@TimKemp See my edit... there's a way to override it by signing the app yourself. I didn't choose this route, but doesn't mean that you shouldn't. –  rm -rf Jul 17 '12 at 21:36
    
I'll investigate your blog link. Thanks for this. It smells like an Apple problem more than a Wolfram one; I have seen the behaviour in some other programs too. –  Tim Kemp Jul 17 '12 at 21:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.