Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I am using the deploy command to embed a CDF file in an HTML page. I am using the annoying but currently necessary fullscreen:'true' trick to reveal the "Enable Dynamics" button. Regardless of what size arguments I use in the cdf.embed function, I get an unnecessary vertical scroll bar in the result rendered in the web page. How can I get rid of this? Are there other undocumented arguments to cdf.embed?

share|improve this question
1  
Welcome over here! We have met almost 20 years ago on the ARVO conference in Sarasota, but you probably don't recall that. BTW If you'd register, you'd be better able to use the site here (includes voting, commenting, and more). –  Sjoerd C. de Vries Jul 10 '12 at 20:46
    
I've read the plugin code and it seems that any javascript present in the fourth argument is just passed on. So, any javascript setting that removes the bar would do. Unfortunately, I don't know javascript, so, I can't help here. –  Sjoerd C. de Vries Jul 10 '12 at 22:08
    
If you have access to a web server account, you can perhaps avoid the issue you're having by serving the CDF directly, not embedded in an HTML page. I noted down the steps for this in the linked answer. This assumes all your content is in the CDF and you just don't like the scrollbar because it's surrounded by nothing else anyway. –  Jens Jul 11 '12 at 6:28
    
Sjoerd: Amazing to hear that we met long ago! I think I am registered. Let me know if you know otherwise. I see my username at the top of the page. –  abwatson Jul 12 '12 at 21:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.