Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I have been trying Yu-Sung Chang's Mathematica.SE answer on volumetric rendering.

This is what the result should look like.

Mathematica graphics

However, I got a different result.

Mathematica graphics

Could anyone help me find what the problem is? Does anyone have a similar problem?

share|improve this question

closed as too localized by rm -rf, Sjoerd C. de Vries Jun 27 '12 at 21:50

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Without looking at the details of your code, it looks like the same rendering problem has been discussed at length (and solved) here: How to show solid bodies using volumetric rendering? –  Jens Jun 27 '12 at 2:52
@Jens Looks like they got the code from Yu-Sung's post — everything (including the comments) is identical. The OP's problem seems to be that it isn't rendering for them. –  rm -rf Jun 27 '12 at 3:21
@R.M Curious, isn't it? –  belisarius Jun 27 '12 at 3:38
@Hyunjoon Soon, first, as Jens already pointed out, you may want to refer to the original answer by me in your question for the people who are not familiar with the post. Secondly, it seems that it could be your hardware--not being able to support 3D texture... It is quite rare nowadays, but it would be helpful if you can post the result from SystemInformation["Devices", "GraphicsDevices"]. Also, the version and OS of Mathematica. –  Yu-Sung Chang Jun 27 '12 at 5:22
I replaced the verbatim copy of Yu-Sung's post in the question (without attribution) with a link to his answer. –  Sjoerd C. de Vries Jun 27 '12 at 8:02
show 11 more comments

1 Answer

I have reported problems with transparent Texture-s before.

Yu-Sung's code works for me with my setting of Automatic of the "Graphics3DRenderingEngine" option in the option inspector (Format > Option Inspector or CtrlShifto).

I found that with the setting "Software" I get about the same, incorrect, result as you reported.

I suggest you try one of the several other options you may set "Graphics3DRenderingEngine" at.

Mathematica graphics

share|improve this answer
None of the possible options (“Automatic”, "HardwareDepthBuffer", "HardwareDepthPeeling", "BSPTree", "Software") for "Graphics3DRenderingEngine” worked on my pc here (bad pc at work). But why is it not possible to change these settings after a new start of mathematica? If I start mathematica all settings are gray. Even if I create an empty notebook, I cannot change them. But as soon as I write something into the notebook, the color changes to black and I can change the settings. Does this have any sense? –  partial81 Jun 27 '12 at 12:03
@partial81 Perhaps you have selected "Selection" in the drop down menu top left of the inspector. It needs to be on "Global Preferences". –  Sjoerd C. de Vries Jun 27 '12 at 12:13
You hit the bullseye! Indeed, I have selected “Selection” and not “Golbal Preferences”. But that has no influence on the fact, that I have the same bad result as Hyunjoon Song. Well, I will try later on my private PC to see if I have there similar problems (hopefully not). –  partial81 Jun 27 '12 at 12:54
It turns out I just needed to update the drivers of my graphic card. Thank you everyone for your help! –  Hyunjoon Song Jun 27 '12 at 20:02
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.