Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I'm trying to export a plot with some added notes which happen to be in Russian.

Using Mathematica 8.04 and WinXP I evaluate

Export["smt.pdf", "Текст на русском", CharacterEncoding -> "WindowsCyrillic"]

Which gives nonsense as output. Is there a way to solve this?

share|improve this question
2  
Possibly related: Mathematica exports to PDF 1.4, which doesn't deal with certain kinds of OpenType fonts (scroll to bottom of the linked answer). –  Verbeia May 17 '12 at 6:34
1  
Works for me on Win7 mma8.0.1 Screenshot –  Ajasja May 17 '12 at 6:57
1  
@user829438 That was just a simple way to demonstrate that it works. Export and ExportString produce the same data---Export will write a readable PDF on my machine (WinXP, Mathematica 8.0.4, like yours). Test Export["test.pdf", "Текст на русском"] again (precisely as I wrote it, don't include CharacterEncoding), and if it still doesn't give you a readable output (try opening with Adobe Reader, that's what I used), then I have one more guess: set the system language to US English, reboot (just in case), and try again. I know it affects some things, e.g. parsing dates. –  Szabolcs May 17 '12 at 9:06
1  
So that solves it, thanks. @Szabolcs, would you post it as a solution or is this problem to local? –  iav May 17 '12 at 11:59
1  
@Szabolcs Brilliant! It works, but precisely, we must change the "Language for applications which do not support Unicode" to US English. I should say that after changing this option my computer now runs only in "Safe mode" and changing this option to its default walue does not help (ordinary run of Windows produces blue screen). I use Mathematica 8.0.4 on Windows XP SP3. Now I will reinstall Windows since I cannot load it in the usual way... –  Alexey Popkov Jul 30 '12 at 14:26

1 Answer 1

up vote 6 down vote accepted

It seems that the problem can be solved by setting explicit value of the CharacterEncoding global FE option (checked with MMa 8.0.4 and 9.0.0):

SetOptions[$FrontEnd, CharacterEncoding -> "UTF8"];
Export["test.pdf", "кириллический текст"]

An equivalent way (without changing the global FE settings):

Export["test.pdf", 
 Style["кириллический текст", CharacterEncoding -> "UTF8"]]

Instead of "UTF8" one may set "UTF-8" or "ASCII" with the same effect. The drawback of this approach is that all non-English letters are outlined.

share|improve this answer
    
Thanks, @Alexey. –  iav Mar 12 '13 at 12:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.