Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This issue appears to be fixed in version 10.1


While this works fine in version 9, in version 10.0 the Antialiasing setting has no visible effect any more

enter image description here

I'm here on Ubuntu 12.04 64-bit with Gnome 3.4.2 and an NVidia GeForce GTX 590 with NVidia driver.

Do others experience this and is there any known solution to the problem?

share|improve this question
    
There is a visible change for me when I move the slider. Bodhi 2.4.0 x64, Radeon HD 3650. – mfvonh Jul 20 '14 at 1:24
    
Given the flashing problem you also reported: which graphics card driver version are you using, and is it the latest? – Oleksandr R. Jul 20 '14 at 2:17
    
@OleksandrR. Currently updating to the latest. I wasn't thinking of this because in all other Mathematica versions and in the beta it worked. – halirutan Jul 20 '14 at 2:25
    
Perhaps they linked against a different library version in the final build that introduced this problem. But this is sheer guesswork. If the problem persists despite the update I suppose you'll have to report it as a bug. – Oleksandr R. Jul 20 '14 at 2:28
    
@OleksandrR. No, nothing changed with the latest driver. I have reported this to wolfram, but I always dislike sending them screencasts, images etc. Therefore, I regularly post the issue here and link in my bugreport to this site. Btw, do I have to mention that all the issues were introduced in the final release version of 10? – halirutan Jul 20 '14 at 8:22
up vote 3 down vote accepted

This appears fixed as of Mathematica 10.1.0, at least on my 32 bit Linux with NVidia Geforce GTX 750 Ti and binary driver 340.46, where the bug does reproduce with Mathematica 10.0.0.

share|improve this answer
    
Yep, seems to be fixed. – halirutan May 16 '15 at 8:23
1  
This is not fixed for me, in 10.1. I'm on a Mac with an NVIDIA GeForce 9400M and OS X 10.10.3. – Dan Fortunato Jul 1 '15 at 22:55

I had to modify the /usr/local/bin/mathematica script to fix 3D antialiasing. It seems that the GLTest script fails and as a consequence Mathematica disables advanced 3D rendering. The fix is to replace the line

GLTestResult=`${GLTest} 1 1 1 2 ${userDisplay}  2> /dev/null | grep "GLTest_OK"`

with

GLTestResult="GLTest_OK"

and now antialiasing works. Seems like a bug or improper test procedure to me. Tested with Mathematica 10.3.0 on Xubuntu 15.10 with Nvidia GeForce GT 730. Note that I did not have to export MATHEMATICA_GL_FBO=1 to enable antialiasing.

share|improve this answer
    
I was wondering, do you have libglu1-mesa installed? – ilian Dec 3 '15 at 14:22
    
@ilian Yes: libglu1-mesa: Installed: 9.0.0-2 – shrx Dec 3 '15 at 14:32
    
@shrx This is an awesome answer, because on my new machine, I swiched to XUbuntu and I have the same problem. Until now, I had no time to investigate further. It seems you did all the work for me :-) +1 of course – halirutan Dec 3 '15 at 21:51
    
@ilian The missing dependency on XUbuntu 14.04 is libMesaGL.so.1 for the gltest program. The library cannot be found although libglu1-mesa is installed. A quick google search gave me no real information why this library isn't there or whether it should be there. Does this help? – halirutan Dec 4 '15 at 2:49
    
@shrx Would you mind to repost your answer here. This is clearly a different bug and we should make an extra question for it. Please don't delete this answer until ilian has seen that we moved the topic. – halirutan Dec 4 '15 at 3:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.