Mathematica Stack Exchange is a question and answer site for users of Mathematica. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Bug introduced in 10.0 and fixed in 10.1


I am trying to use the Dataset functionality which was introduced in Mathematica 10.0 :

   dataset = Dataset[{
      <|"a" -> 1, "b" -> "x", "c" -> {1}|>,
      <|"a" -> 2, "b" -> "y", "c" -> {2, 3}|>,
      <|"a" -> 3, "b" -> "z", "c" -> {3}|>,
      <|"a" -> 4, "b" -> "x", "c" -> {4, 5}|>,
      <|"a" -> 5, "b" -> "y", "c" -> {5, 6, 7}|>,
      <|"a" -> 6, "b" -> "z", "c" -> {}|>}]

But this gives me an error as show in the image below:

enter image description here

I tried the same syntax in combination with

Needs["TypeSystem`"];

but with the same result. How can I resolve this issue?

share|improve this question
1  
I cannot reproduce it. This dataset works well for me, no additional package is needed. – Yi Wang Jul 18 '14 at 9:02
1  
I can reproduce this on OS X. The error message is "An unknown box name (TypeSystem`TypeMap) was sent as the BoxForm for the expression. Check the format rules for the expression." After restarting the kernel it works again. But why did it stop working? That's a good question. – C. E. Jul 18 '14 at 9:21
    
Thanks, you are right, after quit the kernel, the function works. SAnd I have the same issue with the assocation-function – Michiel van Mens Jul 18 '14 at 9:31
    
I don't seem to have the problem in v10.0.0 under Windows. There seem to be a lot of localized bugs in v10.0.0 -- hopefully a lot of them will be fixed in the next point release. – Mr.Wizard Jul 18 '14 at 9:31
    
I ran this on OS X 10.6.8 and it worked perfectly. I had a fresh kernel. – m_goldberg Jul 18 '14 at 9:43

This bug has been fixed as of Mathematica 10.1.0.

The problem had to do with a conflict between the Suggestions Bar and the Dataset paclet code. The same issue has affected other functionality using autoloading in a similar way, for example AssociationMap as mentioned here or here.

It is very likely, as WReach points out in a comment, that this is a manifestation of the same bug.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.