Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

In Mathematica 9 and 10 they added autocompletion. Out of the box this works great, but when I set the CellContext to "Notebook" instead of the default "Global" (following this) it no longer autocompletes the functions I define in my notebook. If I specify that the function is global, then the autocomplete mechanism works as you can see in the example below: enter image description here

Is there a way of making Mathematica's autocompletion work with functions just defined within the notebook, and not just with global functions?

share|improve this question
    
I guess explicitly typing Notebook`My is not an option? :-) –  halirutan Jul 14 at 23:22
1  
@halirutan: In principle that does work, but it is in no way ideal. I would have to find the context and type e.g. Notebook$$21$423901`My, and the context would change every time I would close and reopen the notebook. –  Anders Jul 15 at 14:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.