Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

Mathematica 10 freezes while 'Formatting notebook contents'. This happens already during the startup of Mathematica and it takes a long time for Mathematica to recover. It can also happen when I am editing a Notebook or browsing the documentation. Especially the documentation is very slow.

Is this somehow related to the Mathematica FrontEnd? Is anybody else struggling with problems like this?

EDIT: I'm using 64 bit Windows 7

share|improve this question
5  
Many people are complaining: community.wolfram.com/groups/-/m/t/291668?p_p_auth=D7TZIuwU –  Szabolcs Jul 11 at 22:17
2  
Long shot - but try updating your graphics driver. I had a similar issue with 9.0.1 on one of my machines (where nothing else had any issues) - MM ran fine once started, but it took an inordinate amount of time to start. I traced it to GPU driver, problem gone... –  rasher Jul 11 at 22:34
1  
I have the same problem, but only on my 64 bit Windows 8 (very fast, lots of memory) laptop. Not on my not so fast Windows 7 desktop. –  George Wolfe Jul 12 at 1:17
1  
Likewise - preposterously slow startup and continual "formatting notebook" popups on desktop Win 7 Pro 64 bit, i3, 8GB... and AFAICT latest graphics driver. Lovely ointment, big ugly fly. –  Julian Moore Jul 14 at 7:35
1  
I have the same problem. Additionally, when I click on image inside notebook the last freezes forever. –  Grisha Kirilin Jul 16 at 19:34

4 Answers 4

Wireless keyboard/mouse adaptor may be a cause of a FE issue (there might be others I suppose).

Removing it (at Wolfram's suggestion - credit for investigation so far) made MMA10 startup speed effectively normal & no "formatting notebook" popups were noted. Unfortunately I don't have a wired keyboard & mouse...

[Setup i3, Win-7 pro 64-bit; all Acer hardware].

Additional info: running kernel directly showed no autocomplete lag on entering test expressions for evaluation, suggesting the issue is related to the FE.

See also my post at Wolfram community

share|improve this answer
    
I have removed the keyboard and mouse, but the problem remains. –  Anixx Sep 5 at 12:29
up vote 1 down vote accepted

Issue resolved with the recent update to Mathematica 10.0.1. The startup of Mathematica still takes quite a long time, but afterwards the notebook won't freeze anymore. 'Formatting notebook contents' only occurs on startup MMA and on closing a notebook.

share|improve this answer

I have the same problem. In my case what helps is removing the second (external) monitor. Removing wireless mouse and/or keyboard does not affect the behavior at all. After switching to the notebook's internal monitor Mathematica always loads quickly.

share|improve this answer
    
Just confiming in case exchange above is not noticed: unplugging the monitor on HDMI output of my Packard Bell ixtreme M5741 resolves the issue; unplugging the other output (15 pin subD) does not - even with generic monitor drivers. But I notice that the "formatting notebook" issue is in fact still there when there are startup and autocoplete issues - only noticed it this time because I quit the notebook instead of killing MMA this time. –  Julian Moore Sep 11 at 11:14

It seems that manually changing the monitor's driver to "Digital flat panel (1920x1200 60 Hz)" is the best solution in my case!

enter image description here

share|improve this answer
    
An interesting observation - with similar +ve results here. I have a desktop with dual monitors having different resolutions; I set the displays to Mirror rather than Extend desktop (Lowest common denominator resolution used) and found a) MMA started quicker b) There were no "formatting notebook" messages and c) the Autocomplete delay issue was almost eliminated. [I have no idea about access to EDID control under Windows 7 (64 bit)] –  Julian Moore Sep 8 at 18:51
    
@Julian Moore Effectively the control changes the driver to "Universal non-PnP monitor". While this helps with Mathematica, some games start to set wrong resolution. So the best thing that worked for me is to change the monitor's driver to "Digital flat monitor (1920x1200 60 Hz)". After doing so, both Mathematica and games work well so far! –  Anixx Sep 8 at 23:29
    
Further diagnostic info for Wolfram: made sure both monitors were set to the same refresh rate (60Hz) rather than 60Hz/59Hz - no change; then also set both monitors to 1920x1080 instead of 1920x1200/1920x1080 (the desktop extended across both) no change. Used only HP2310i on 15pin subD from PC and MMA starts up fine. Used only Dell U2412M on HDMI output - MMA startup not fine Used only Dell U2412M on 15pin subD from PC and MMA is fine again. Note that both displays driven from motherboard with Intel Graphics. Conclusion: not the monitor/driver per se but monitor/driver/graphics port??? –  Julian Moore Sep 9 at 12:44
    
@Julian Moore did you try to change the monitor's driver? –  Anixx Sep 9 at 13:19
    
I have now set both mnonitors (Dell, HP as above) to use the Generic PnP Driver; no difference to extended startup time or autocomplete delay which render MMA unusable. Again setting identical resolutions on both displays (with generic driver) also made no difference, but again setting the displays to Duplicate instead of Extend made everything fine: MMA started up and was usable within ~8s. NB I don't seem to be seeing the Formatting Notebook issue at all anymore, regardless of settings. PS Is Wolfram monitoring all this or do I need to pass it on directly? –  Julian Moore Sep 11 at 7:38

protected by Community Aug 31 at 1:11

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.