Sign up ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

For some reason when I use ?function-name to ask for help on a function, I got a very clinical breakdown of that function with its options and attributes instead of the blurb about the function:


To fix this, I evaluated ClearSytemCache[], killed the kernel (Evaluation > Quit Kernel > Local), and restarted Mathematica -- it's possible that I had to do only one of these steps -- after which the problem went away.

?Function fixed

However, I was just curious about what brought it on.

share|improve this question

closed as off-topic by Oleksandr R., Lou, Karsten 7., MarcoB, Michael E2 Nov 19 at 20:19

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question cannot be answered without additional information. Questions on problems in code must describe the specific problem and include valid code to reproduce it. Any data used for programming examples should be embedded in the question or code to generate the (fake) data must be included." – Oleksandr R., Karsten 7., MarcoB, Michael E2
If this question can be reworded to fit the rules in the help center, please edit the question.

Don't know what caused the problem, but note that what you were seeing is what you would obtain had you evaluated ??ParametricPlot3D (with two question marks), which is an abbreviation for Information[ParametricPlot3D]. – murray Jun 7 '14 at 15:13
Didn't know this. Thank you! I learn something new here everyday. – seismatica Jun 7 '14 at 15:32
I cannot reproduce this behavior on Win7 64bit. – Yves Klett Jun 8 '14 at 8:50
I don't know what I did to get it either as I only very occasionally get that glitch. Also, I got it again a moment ago and found that quitting the kernel was enough to fix it. – seismatica Jun 8 '14 at 20:17