Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I'm starting to use Wolfram Workbench 2 to develop a Mathematica package. For the first time I tried "Documentation - Build" under the "Application Tools" but got fatal errors:

BUILD FAILED /Users/[...]/docbuild.xml:132: The following error occurred while executing this line: /Users/[...]/docbuild.xml:90: taskdef A class needed by class com.wolfram.jlink.util.MathematicaTask cannot be found: org/apache/tools/ant/Task

This is with Mathematica 9.0.0.0 on a Mac with OS 10.9.

Any idea on what's wrong here?

share|improve this question
    
I would guess that you don't have ant installed properly. –  halirutan Jun 2 at 17:21
    
Chris, did you try to create documentation and build the NumericalAnalysis package bundled with WB 2.0 ?This package comes with documentation. See if you get the same error with it. If yes, then the problem lies in your WB installation, overwise the problem is perhaps in the way you wrote the documentation. Also: do you get other messages? Normally WB is very verbose, telling you about every step it is doing. Is there anything that went well during the build? –  magma Jun 3 at 13:42
    
Thanks for the idea. Although the problem fixed itself (see my answer below), I couldn't locate the NumericalAnalysis package you mentioned. –  Chris K Jun 4 at 13:31
    
@ChrisK the NumericalAnalysis package should be available on the WB site under Examples. You probably have to download it –  magma Jun 5 at 11:26

1 Answer 1

up vote 0 down vote accepted

I tried again this morning after restarting Workbench and it worked fine this time. Mysterious!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.