Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I see ContourPlot3D doesn't show the X, Y, Z axis by default (i mean inside the graph), i tried adding ",Axis->True" to the call, but doesn't make effect.

How to do this?

share|improve this question
2  
Try Boxed -> False ... the axes are there by default –  belisarius May 21 at 21:27
    
@belisarius Ok, that is not how i want to se the axis, i mean the axis centered in the graph... is possible? –  Wyvern666 May 21 at 21:38

1 Answer 1

up vote 1 down vote accepted
ContourPlot3D[
 x^3 + y^2 - z^2 == 0, {x, -2, 2}, {y, -2, 2}, {z, -2, 2}, 
 Boxed -> False, AxesOrigin -> {0, 0, 0}, Mesh -> None]

Mathematica graphics

share|improve this answer
    
Exactly what i want, thanks! –  Wyvern666 May 21 at 21:45
    
There is only one more thing, why the axis labels are never show? –  Wyvern666 May 21 at 21:47
1  
@Wyvern666 They are also there, but ugly positioned ContourPlot3D[ x^3 + y^2 - z^2 == 0, {x, -2, 2}, {y, -2, 2}, {z, -2, 2}, Boxed -> False, AxesOrigin -> {0, 0, 0}, Mesh -> None, AxesLabel -> {x, y, z}, LabelStyle -> Directive[20, Bold]] –  belisarius May 21 at 21:50
    
Ok, is ugly but not so important anyway. Thanks! –  Wyvern666 May 21 at 21:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.