Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I am running Windows 8.1 on a ThinkPad T540P with a 3K screen, which is equivalent to Apple Retina screens. I have configured Windows to increase the magnification of the desktop to make fonts legible. When I open a CDF using CDF Player 9.0 the resulting image appears magnified, although it does not display fonts using ClearType. When the CDF is embedded in a browser window, the height and width of the tag are magnified appropriately but the CDF itself is not, appearing smaller than the embedding area. Does anyone know of a way to force the CDF plugin to use the actual rendered size of the magnified embedding area? Thanks.

share|improve this question
    
related question on superuser. Sounds like the answer is no, CDF plugin isn't aware of the actual rendered size of the embedding area. –  bobthechemist Apr 5 at 14:49
    
Thanks for the link. It actually does contain an answer that works with a slight tweak. –  Paul Masson Apr 5 at 23:36

1 Answer 1

up vote 1 down vote accepted

The behavior of the CDF player plugin is controlled by an initialization file, just like Mathematica and the stand-alone Player program. This file can be edited in Mathematica or with a text editor.

The location of the plugin initialization file for the stand-alone player is

C:\Users\USERNAME\AppData\Roaming\MathematicaPlayer\Autoload\PacletManager\Configuration\FrontEnd\init_VERSION.m

and the location for the player installed along with Mathematica is

C:\Users\USERNAME\AppData\Roaming\Mathematica\Autoload\PacletManager\Configuration\FrontEnd\init_VERSION.m

The apparent size of the player is controlled by adding the line

Magnification->1.5

with a comma either before or after to separate it from the other options. In practice the number used should be less than the actual Windows desktop magnification to avoid clipping of the displayed image by the embedding area.

These files get overwritten when the plugin exits naturally. This can be prevented by making the files read-only after editing, with no apparent error messages or problems.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.