Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

Local variables in Module are no longer specially colored for me, but other syntax coloring remains, for example iterators in a Table:

enter image description here

What causes this? How can I restore the original syntax coloring behavior?

The altered behavior has persisted across hundreds of rebootings and new notebooks.

And the preference for "local variables of Module and With" is correctly set, but shows the incorrect behavior in the example:

enter image description here

Resetting to defaults does not restore order. Changing the color to something different also has no effect.

Restarting after clearing the init.m file using:

RenameFile["~/Library/Mathematica/FrontEnd/init.m", "~/Library/Mathematica/FrontEnd/init.m_Backup"]

also does not change the behavior.

share|improve this question
1  
1. youtube.com/watch?v=p85xwZ_OLX0 2. If that doesn't work, have you checked Preferences -> Appearance -> Syntax Coloring -> Local variables? Try the Reset to Defaults button on that page. –  Szabolcs Mar 4 at 23:16
1  
@Szabolcs, yes, and I'm absolutely sure it's plugged in. See edits. –  ArgentoSapiens Mar 4 at 23:28
    
Remove (backup) your front-end's init.m file and see if it works (it should). –  rm -rf Mar 4 at 23:36
    
Before you remove the init.m file, you can try this simpler thing: hold down Command+Shift while starting up Mathematica and see if it fixes it. If it doesn't, then try what @rm said. –  Szabolcs Mar 4 at 23:43
    
Clearing the user-level init.m in ~/Library/Mathematica/FrontEnd/ doesn't work. Is there another system-wide one I should try clearing out? Starting with Command+Shift also doesn't work. –  ArgentoSapiens Mar 4 at 23:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.