Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I installed Adobe Type 1 Times Roman SC (small caps) and Times Roman Bold SC fonts on my Mac OS X system. Now every old or newly-created Text style cell in every Mathematica notebook appears in small caps!

This is with the Default.nb style sheet.

Why? And how to fix.

Uninstalling the two fonts did cure the problem, but it makes no sense to me that this should have happened. Note that the Options Inspector shows the font settings for the Text style as being Times, 12, Plain.

share|improve this question
    
Did you change file names or did you process the font files with a font utility? What names do your font files have? –  Sjoerd C. de Vries Apr 15 '12 at 15:28
    
The files are TIRSC___.pfb and TIBSC___.PFB dated Jan 25 1999 and their internal font names are Times-RomanSC and Times-BoldSC. I believe these are the originals as I bought them directly from Adobe. I installed them in OS X Lion simply by using Font Book's menu item File > Add fonts... dialog. –  murray Apr 15 '12 at 19:24
add comment

1 Answer

The Text style uses FontFamily->"Times". Your fonts are almost certainly set to have the same family name as the built-in font that Mathematica normally uses, and leaves the system with two possible sets of fonts to choose from. Even though the internal font name being used is, e.g., Times-RomanSC, that's not the actual family name...that's the style name (I'm not sure how standard the term "style name" is, but it's the term that FontLab uses for this).

As a result, Mathematica asks for "Times", and this font shows up in the list of candidates. Mathematica will choose the first font the system offers from that list. I would have expected Mathematica to understand that this is a small caps variant, and not use the font unless you wanted small caps, but it's entirely possible that the variant information in the font is not declared in a way that Mac OS X recognizes, probably due to it using older, Type 1 technology. I wouldn't be surprised if other applications on your system have similar problems.

If you could edit your small caps fonts to change the font family name, that would certainly fix things. This isn't about the filenames being used by the font...this is about the inherent family name set as a property of the font itself. You'll probably need to change the style name to match as well.

Otherwise, you could use the Format->Show Fonts menu item to see if it's possible to pick the correct Times font and, if so, determine what the properties are by looking at the underlying cell expression (Cell->Show Cell Expression). Armed with that information, an expert could help you figure out how to modify options/styles to avoid this.

share|improve this answer
1  
OK, this explains what's happening. (Years ago, I had a similar issue - not concerning Mathematica - with "internal" font names vs. file name that Berthold Horn helped me resolve.) As I wanted the Times Small Caps fonts just for use with TeX, I've simply removed them from the normal font locations and put them into my local texmf tree. –  murray Jun 10 '12 at 15:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.