Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I have a polynomial $f(x_1, x_2, \ldots , x_n)$ with coefficients in $Z[q,t]$, and I have a list of polynomials $g = g_1, g_2, \ldots , g_k$ where they are also polynomials in $(x_1, x_2, \ldots, x_n)$ and with coefficients in $Z[q,t]$. (Note that we are using specific values of $n$, like $n=3$ or $4$.)

I am using PolynomialReduce$[f, \{g\}, \{q,t\}]$ to try to find the coefficients when $f$ is written as a $Z[q,t]$ linear combination of polynomials in $g$. However Mathematica always ouputs coefficients with $x_1, x_2,$ etc. when I only want $q$ and $t$ to be in the coefficients.

Update: Upon suggestion, I also tried PolynomialReduce$[f, \{g\}, \{x_1,x_2, \ldots x_n\}]$ for the input, but mathematica still outputted coefficients with $x_1$, $x_2$, etc.

For a couple of test cases I tried, I know for a fact that $f$ can be expressed as a $Z[q,t]$ linear combination of polynomials in $g$, so that is not the issue. Why is this happening? What can I do to fix it?

share|improve this question
2  
Please, provide a minimum non-working example to illustrate the problems. –  Sektor Feb 21 at 8:12
    
Your question potentially interesting cannot be answerd in this form. It seems you've misunderstood how PolynomialReduce works. See e.g. this recent answer how it can be used How to substitute the following conditions into an expression? –  Artes Feb 21 at 11:25
1  
Cannot say much of anything without a concrete example. –  Daniel Lichtblau Feb 21 at 16:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.