Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

This is a strange problem and everything I tried did not work.

I have a very large single Manipulate cell (it is a demonstration stylesheet notebook, hence this cell have to be one), and I simply wanted to copy the content of this cell and paste it into another text file.

It seems that, for some reason, Mathematica has a limit somewhere, since I am sure the windows 7 clipboard can handle this size itself.

When I select the cell, and then do CTRL-c, and paste into a plain text file in my editor, the output that shows up is only about 850 lines (this is much less than the original cell, which is I think few thousands lines long). I tried two different editors with the same result. It always gets cut off at the same place.

The copy has to be done as input text and not as plain text. The copy as plain text is able to copy the whole cell, but the formatting is all messed up and not possible to read.

I need to copy it as input text, which what happens when selecting the cell and doing CTRL-C, then CTRL-V (on windows)

I can save the whole notebook as .txt file, but again, the formatting is all lost, and it seems to save it using the plain text mode.

I can offocurse break the cell into many smaller cells, and then copy one by one with the mouse, but this is very tedious way to do it and I think there should be a way to handle this directly.

Here is the notebook and I hope someone can find a way. I have many such notebooks with large cells to do.

I am using version 9.01 on windows 7 64 bit.

share|improve this question
    
Nasser, are you after a Guinness world record with a multi-kilo cell? (^_-) –  Yves Klett Dec 30 '13 at 6:40
    
@YvesKlett not at all. But as I said, this a demonstration. Hence one has to use one cell for Manipulate controls and one cell for the initialization section. No more. This is the largest demo I did, took about 9 months. I learned my lesson since not to make them so large :) it is strange why the copy/paste fails on this one, as I have been able to copy demos with about 2,800 lines with no problem. But this is larger than this. Yet the result only has 850 lines copied. May be a setting needs to be modified somewhere. –  Nasser Dec 30 '13 at 6:47
    
Works as it should on Mac OS X, Mathematica 9.0.1 - copied all 3011 lines as Input Text into a text editor. So it might be a Windows-specific issue... –  cormullion Dec 30 '13 at 10:15
1  
@Nasser how about this? Cheaper than a Mac ;o) –  Öskå Dec 30 '13 at 13:27
1  
Is there something in the 850th line that is being interpreted by the Win 7 clipboard as a null character? I guess if this were the case it would be MS Word doing the mis-interpreting. –  bobthechemist Dec 30 '13 at 13:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.