Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

When I try to use model files generated by FeynRules in FeynArts, I always get errors of this form

Coupling definition in model file for C[S[5],S[1,{e2x1}],-V[3]] is \ incompatible to generic coupling structure. Coupling is not a vector \ of length 1.

(when I use the InsertField function, InsertFields[t11, {S[7], -S[7]} -> {S[2], S[2]}, Model -> "NMSSM"], etc.)

I have tried using the SM and NMSSM models included with FeynRules, and my own models and I get the same error. When I tried using the SM model file that's included with FeynArts, there's no problem. So it seems there's a problem with the FeynArts model files generated by FeynRules?

I'm using FeynRules 2.0.3 and FeynArts 3.9.

share|improve this question
add comment

1 Answer

You did not load the generic model:

InsertFields[t11, {S[7], -S[7]} -> {S[2], S[2]}, Model -> "NMSSM"]

should be replaced with

InsertFields[t11, {S[7], -S[7]} -> {S[2], S[2]}, Model -> "NMSSM", GenericModel -> "NMSSM"]

The Model option loads NMSSM.mod, the GenericModel loads NMSSM.gen.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.