Sign up ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I'm running a webMathematica server (running Mathematica 9) and am getting some weird stuff in the log - specifically, I keep getting the following message:

General pool request background 61 > [      ] Input MSP`Utility`DestroyRequest[] generated message:
Remove::rmnsm: There are no symbols matching "Global`$InterfaceEnvironment".

I can't find any documentation for this, so it's possible that this is a user created symbol that I'm not seeing, but I think this is unlikely. Is this error something I should worry about?

share|improve this question
I know it's a long time ago, but now I'm experiencing the same issues. Moreover, Tomcat seems to be stopped by such errors and the website is no longer available until I restart services. So, my question is about how you have solved this problem or if you have any suggestion about that. Thanks, Roberto – bobknight Jul 21 at 11:57
@bobknight Unfortunately, I never managed to solve this issue, but It also never caused the service to stop. Are you sure this is the cause of the problem? From what I was able to divine, similar error messages appear when Java objects are used with msp:set and msp:get, and it might have something to do with memory management. – Daniel Jul 21 at 12:28
thanks for the answer. I'm not sure that this is the cause of tomcat's crashes, however this is the main message I found in catalina.log. Unfortunately there are no other useful information in the logs and I'm just doing some hypotesis. – bobknight Jul 21 at 12:45

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.