Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I am currently working with a list containing around 20 strings which contain around 30,000 characters each. The strings are imported from PDFs and the list containing all the strings is assigned to a variable. So far so good. However, when I evaluate the list (e.g., evaluate variable, then evaluate subsequent output) I get the following error message:

Syntax::tsntxi: "<<1>>" is incomplete; more input is needed.
Syntax::sntxi: Incomplete expression; more input is needed .

I have tried the same procedure on other computers running Mathematica, but I get the same result. Unfortunately, I am unable to provide a minimum working example, so I'll be happy to provide any additional information that might help.

share|improve this question
1  
Take one of the strings and see if you get the same error. If so, take half the string and see if you get the error. If so, cut it in half again, until you either get something that works or something that fails and is small enough to ask about. –  bill s Dec 7 '13 at 3:03
    
Is VectorQ[theVariable, StringQ] true? If so and the same error happen with newVariable = StringTake[theVariable, 1] you can provide that as an example. –  ssch Dec 7 '13 at 3:04
    
@bills I went through the string and got: "V\.00" This still gives an error. –  E.O. Dec 7 '13 at 3:26
1  
What command do you use to import the pdf? Perhaps there is a way to sanitize the strings before Mathematica has time to go crazy –  ssch Dec 7 '13 at 4:06
1  
Also if there are characters not belonging to the plane 0 of Unicode, Mathematica may fail to interpret them. –  Silvia Dec 7 '13 at 4:13
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.