Mathematica Stack Exchange is a question and answer site for users of Mathematica. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Mathematica 9.0.1 under OS X.

In order to have separate contexts for each of my notebooks, I used the instructions in the last part of the accepted answer from the following link:

Is there a way to separate variables between multiple notebooks?

To quote the relevant part of the answer:

"To set this automatically for all new notebooks, open the Options Inspector (Ctrl/Command+Shift+O), and change the scope to "Global Preferences." Then, the option CellContext is found under Cell Options -> Evaluation Options. Change it to "Notebook."

However I've found that after I do this, I lose auto-completion suggestions for symbols that I define in my notebook(s). Is there any way to fix this?

share|improve this question
No problems with autocompletion for me on OS X. Did you set the notebook context after you already loaded the notebook with variables or before? If the former then evaluate the notebook and try autocompletion again. – Mike Honeychurch Dec 1 '13 at 8:01
@MikeHoneychurch I simply quit and restart mma, and worked with fresh notebooks – Aky Dec 1 '13 at 8:04
I confirm the behavior you report. I am also running V.9.0.1. I have found that selecting choice for CellContext except "Global`" induces the behavior in question. – m_goldberg Dec 1 '13 at 23:38
@m_goldberg Thanks for the confirmation. It appears to be a bug. – Aky Dec 2 '13 at 5:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.