Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

This is a rather simple numerical solution, but it simply doesn't work. Does anybody have a solution?

NSolve[x - Sinh[x] - 1 == 0, x]

NSolve::nsmet: This system cannot be solved with the methods available to NSolve.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted
NSolve[x - Sinh[x] - 1 == 0, x, Reals]
(*
 {{x -> -1.72912}}
*)
share|improve this answer
    
That is strange, since the first thing I tried is this: Assuming[Element[x, Reals], NSolve[x - Sinh[x] - 1 == 0, x]] and it did not work ! I see from help now that NSolve takes Reals as second argument. But this is not very consistent with how other functions work, by using Assuming. –  Nasser Nov 19 '13 at 7:12
1  
@Nasser I don't think the assumption is taking effect on the NSolve "Block[]" –  belisarius Nov 19 '13 at 7:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.