Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I'm trying to solve a simple PDE in Mathematica. I just can't get Mathematica to give me an explicit analytical solution. This is the code that I made and it basically repeats in the output what I have given in the input.

Below are my input and output. What am I doing wrong?

pde = D[u[z, t], {t, 1}] + const* D[u[z, t], {z, 2}] == 0
DSolve[pde, u[z, t], {z, t}]
(u^(0,1))[z,t]+const (u^(2,0))[z,t]==0
DSolve[(u^(0,1))[z,t]+const (u^(2,0))[z,t]==0,u[z,t],{z,t}]
share|improve this question
    
yes, I have, but how do I know that is the wrong syntax? I've never used this part of Mathematica before. The DSolve doc was not very helpful, which I came here. –  lomppi Nov 1 '13 at 13:33
    
actually, I do not get any messages (I thought you meant the output). I'm running Mathematica 9. It does not give me any error messages. –  lomppi Nov 1 '13 at 13:45
1  
2  
The short answer is that mathematica can't solve the heat equation symbolically. NDSolve does though but you have to specify appropriate boundary conditions. i.e. (const=-1) sol = NDSolve[{D[u[z, t], t] - D[u[z, t], z, z] == 0, u[-1, t] == t, u[z, 0] == 0}, u, {z, -1, 1}, {t, 0, 1}]See this and therein references about the warning. –  gpap Nov 1 '13 at 14:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.