Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I am trying to make a legend for a simple plot in Mathematica 8, but does not seem to recognise the command PlotLegends. I declared beforehand Needs["PlotLegends`"], and get this message:

Needs::nocont: Context PlotLegends` was not created when Needs was evaluated. >>

I also tried to install this pakage manually by going to File -> Install -> .... I am not very experienced with Mathematica, so an answer for dummies will be appreciated.

share|improve this question
    
Perhaps you have spelled the name of the package incorrectly. You get the same error message if you use a lowercase l or a double backtick quote instead of a single one. –  Sjoerd C. de Vries Oct 9 '13 at 20:20
    
Try in a "fresh" kernel. First evaluate Quit to quit the kernel. Then immediately, evaluate Needs["PlotLegends`"]. Do you still get this error message? If yes, your Mathematica installation is either broken, or you have accidentally installed something named "PlotLegends" into your $UserBaseDirectory which is conflicting with loading the package that is bundled with Mathematica. Evaluate $UserBaseDirectory to see where this location is, open it, and check that the Applications folder doesn't contain anything named PlotLegends. If it doesn't then try reinstalling Mma. –  Szabolcs Oct 10 '13 at 0:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.