Sign up ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I am unable to get the CountryData function to work. I have tried FinancialData, CityData, WeatherData, AstronomicalData, and ProteinData. They all work.

CountryData["France", "Population"]
FinancialData["GE", "MarketCap"]

I wonder if the internet connection is different for CountryData but can't find a setting to change anything. I'm running

share|improve this question

closed as off-topic by MarcoB, Pickett, blochwave, Oleksandr R., m_goldberg Sep 29 at 23:04

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "The question is out of scope for this site. The answer to this question requires either advice from Wolfram support or the services of a professional consultant." – MarcoB, Pickett, blochwave, Oleksandr R., m_goldberg
If this question can be reworded to fit the rules in the help center, please edit the question.

WinXP V9.01 Out:=6.47684*10^7 – Kuba Sep 13 '13 at 12:50
same population on MacOS X v9.01. – Pinguin Dirk Sep 13 '13 at 12:54
Do you get the "installing data from wolfram" box or does it $Failed right away? Either way, I'd try a) quit mathematica b) remove the directory FileNames[ FileNameJoin[{$UserBasePacletsDirectory, "Repository", "CountryData-*"}]] c) start mathematica and see if it gets loaded right – ssch Sep 13 '13 at 12:54
If that solves if please post as an answer. – s0rce Sep 13 '13 at 13:00
Sorce: I tried your suggestion. I deleted two directories and restarted Mathematica (CountryData-7.0.59 and CountryData-8.0.62). No Change. Regarding first question: The failed response happens pretty much right away, no message, "installing data from wolfram". Thanks – Jeff Lapides Sep 13 '13 at 15:01

Browse other questions tagged or ask your own question.