Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

Is it possible to format usage messages (with italic arguments etc) such that Mathematica 9 still parses function templates correctly?

For example, plain usage messages work when pressing Ctrl+Shift+K:

enter image description here

But formatted ones don't:

enter image description here

Note that this does work correctly on Mathematica 8, so I guess this is a bug on Mathematica 9.0.1. Nonetheless, is there a workaround?

share|improve this question
    
There are also major problems with this functionality working with add-on packages too. –  wolfies Aug 8 '13 at 19:13
    
I have reported this as a bug. Thanks. –  user21 Aug 9 '13 at 7:41
    
@Teake Did you get any response from Wolfram Tech Support confirming this is a bug? If so, could you please post it as an answer? –  István Zachar Jan 20 '14 at 17:18
    
I didn't report this; perhaps @user21 received some feedback? –  Teake Nutma Jan 20 '14 at 20:30
    
@TeakeNutma user21 does not care :) so maybe you could report this? :) –  Kuba Apr 26 '14 at 8:03

1 Answer 1

This specific example works Mathematica 10.0.2:

enter image description here

However, there are several variations that do not work and these are tracked by Wolfram, currently as an open issue [247087].

Here is a slight modification of the original example which does not work:

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.