Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

After updating to version 9, I found the predict interface very helpful except there is a small problem always annoying me:

Consider this:

I have a list abc = Range[1, 10]; and I want to take part of it abc[[2]].

For the [[ and ]], I like to use the closer version of the bracket (\[RightDoubleBracket]) by press key Esc+[+[+Esc and Esc+]+]+Esc.

enter image description here

In version 9, when I type abc I get this drop list of predictions, and the first Eec key goes to remove the drop list and the [[ is not correctly typed:

enter image description here

enter image description here

So it is possible to make the drop list automatically disappear once what I typed matches the exists variable, so that the first Esc key is not eaten by the drop list?

share|improve this question
3  
You could uncheck the "Enable autocompletion..." box in Preferences, Interface. Then use Ctrl+K or Shift+Ctrl+K when you want it. My personal opinion is that the automatic autocompletion is a nuisance. –  David Park Aug 3 '13 at 22:42
4  
You could use an alternative method for entering the [[/]] characters; it's faster, too. –  Mr.Wizard Aug 3 '13 at 22:49
1  
Just form the habit of hitting the first escape twice when in this situation. –  m_goldberg Aug 4 '13 at 6:24
    
@m_goldberg that's what I've done :) –  P. Fonseca Aug 4 '13 at 7:35
    
@DavidPark The predictive interface is actually a very useful thing and if I turned it off, I would really miss it ... At the same time these types of issues (described in this question) are extremely frustrating. I assume you (or xslittlegrass) did describe the issue to WRI support in the hope of getting some attention? –  Szabolcs Oct 30 '13 at 21:10

1 Answer 1

up vote 10 down vote accepted

[This late "answer" or work-around is based on comments I made on a duplicate to this question which I just revisited.]

To get around this annoyance I have increased the autocompletion popup delay to 0.6 seconds. This enables me finish typing an existing symbol name and hit the Esc key before the autocompletion popup appears to "eat" the key-press.

This has greatly reduced the number of times I end-up having to backtrack to insert escapes.

The popup delay is found in the Interface tab of the Preferences dialog, where you enable or disable autocompletion.

You can of course change the value to accommodate your own typing speed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.