Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I know there has been a similar questions to this already but the solution did not work for me so here again:

I have internet connection and I can execute such commands like:

Import["http://www.google.com"]

I am also able to use the functionality of Wolfram Alpha such as

== GDP of the USA

but when I do

CountryData["France", "Population"]

it tells me that there is no connection and that I should test the connectivity which I did via "Edit->Preferences->Internet Connectivity->Test Connectivity". When I tried testing it it returned:

"PacletSiteUpdate::err: An error occurred attempting to update paclet information from site http://pacletserver.wolfram.com. Failed writing received data to disk/application"

When I tried to ping the pacletserver.wolfram.com directly in the cmd it tried to ping pacletserver2.wolfram.com which failed. When I did the same with pacletserver1.wolfram.com and pacletserver3.wolfram.com it worked just fine.

So I tried Nikita's Solution with the windows host file which did not work for me.

After that I tried to change the server address within Mathematica with

$PacletSite = pacletserver1.wolfram.com

After that the Connectivity Test returned success. The CountryData-function did still not work, though. When I re-started Mathematica the $PacletSite contains the original value (http://pacletserver.wolfram.com) and the Connectivity Test fails again.

Even though the CountryData-function did not work, I think that the problem is that Mathematica tries to connect to pacletserver2.wolfram.com and the $PacletSite-Value does not influence the CountryData-function.

So is there a way to change the way Mathematica tries to connect to the pacletserver and tell it only to connect to pacletserver1.wolfram.com or pacletserver3.wolfram.com?

Thank you very much for your help

share|improve this question
    
What version of Mathematica is this? –  Todd Gayley Jul 26 '13 at 15:48
    
Mathematica 9.0.1 and I am using Windows 7 –  Tom Jul 27 '13 at 20:14
2  
In version 9, try setting PacletManager`Services`Private`$wriPacletServerIndex = "1" (note that the value is a string). Use "1" or "3", or whatever pacletserverN.wolfram.com value works for you. I might contact you separately to try to determine why the built-in failover mechanism doesn't appear to be working. –  Todd Gayley Jul 27 '13 at 21:28
    
Unfortunatly it did not work. I thin that the built-in failover mechanism works beacuse the problem is just the http:// value. The original Value of $PacletSite is http://pacletserver.wolfram.com when I don't change that and set PacletManagerServices`Private`$wriPacletServerIndex = "1"` the Connectivity Test fails. As soon as I set $PacletSite = pacletserver.wolfram.com even without PacletManagerServices`Private`$wriPacletServerIndex = "1"` the Connectivity Test is successful. The CountryData-function still does not work, though. In addition the is default again after a re-start. –  Tom Jul 28 '13 at 13:11
    
I have the same problem in a user account with non-ASCII characters in the name. Does your Windows user name have accents? Try CountryData["France", "Population"] in your administrator account. –  Hector Jul 31 '13 at 13:15
show 1 more comment

1 Answer 1

I had EXACTLY the same problem and the cause actually seemed to be a Windows user name with non-ASCII character. A simple change of the user name through control panel does not help though as the underlying user name remains the same. Creating a new account with only ASCII characters solved the problem for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.