Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

Selecting text in one of my Notebooks becomes abnormal.

Here is the unselected text:

enter image description here

and here is the partly selected text:

enter image description here

When the text being selected, it should be like this:

enter image description here

What is wrong with this Notebook? my other Notebook is OK!

Here is my abnormal Notebook.

share|improve this question
    
Behavior confirmed in version 7, but I don't know what is causing it. –  Mr.Wizard Jul 19 '13 at 1:41
    
Similar behavior in V9.0.1 on OS X 10.5.8 –  m_goldberg Jul 19 '13 at 2:07
    
If I do a Select All on the downloaded notebook, copy the selection, and paste it into a new notebook, highlighting works as expected in the new notebook. Perhaps you can do the same to recover control over your work. –  m_goldberg Jul 19 '13 at 2:28
    
This question appears to be off-topic because it is too localized; i.e, it applies only to local situation and needs of its poster. –  m_goldberg Jul 19 '13 at 2:29
1  
@m_goldberg You may have noticed that "too localized" is no longer a listed reason for closing. ;-) Anyway, in this case I disagree as it's a curious problem until the solution is revealed, and it could potentially affect anyone who comes across such a Notebook. –  Mr.Wizard Jul 19 '13 at 6:18

1 Answer 1

up vote 7 down vote accepted

Your notebook has an option set, ShowSelection -> False, which is causing the problem. Use the Format > Option Inspector... and search for ShowSelection; then click the checkbox to set it to True. Or execute SetOptions[EvaluationNotebook[], ShowSelection -> True] in the notebook.

share|improve this answer
    
Nice catch! I don't think I've ever seen that option before. –  Mr.Wizard Jul 19 '13 at 6:07
    
@Mr.Wizard why it doesn't work for me? The option is false, but I can't make it True. Because it is grey! After I ran "SetOption[EvaluationNotebook[], ShowSelection -> True]", the option is changable. But just for one time. When I look it second time, it becomes false again. –  matheorem Jul 19 '13 at 6:10
1  
@matheorem It worked for me; I used the Option Inspector, chose Selected Notebook in the drop-down menu, and then found the option by typing it in the search field. I reset the option by clicking the "X" to the left of option name. –  Mr.Wizard Jul 19 '13 at 6:17
    
@Mr.Wizard "choose Selected Notebook", this step is essential to success. Thank you Mr.Wizard ! –  matheorem Jul 20 '13 at 8:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.