Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

When I want to copy a scientific notated number from a TraditionalForm output to an input it formats it in a weird way:

enter image description here

Another thing I want to do is only copy a few number of decimals, and remove the accent (`), at the end:

enter image description here

share|improve this question
    
Out of curiosity, how did you get Mathematica to use a decimal comma and a center dot for multiplication? Here it always uses a decimal point and a cross regardless of locale settings. –  Szabolcs Mar 11 '12 at 11:16
    
In the preferences here: i.imgur.com/AbdFR.png and here: i.imgur.com/WMbMk.png –  Tyilo Mar 11 '12 at 11:19
    
Ah, I see. Could you explain why you want it copied as-is? I find that Mathematica only does this when pasting the expression to be used as input (therefore ensuring it will get correctly interpreted), but it doesn't do it when pasting it to be used as typeset expression (e.g. text cells). –  Szabolcs Mar 11 '12 at 11:21
    
Because I want to make multiple calculations, continuing from the last result, which would be in a TradionalForm input and it would save me some time, as I currently have to fromat it myself. –  Tyilo Mar 11 '12 at 11:46
1  
A practical workaround is to copy as MathML. But be aware that then you will be copying what you see, and it might get misinterpreted by Mathematica on the next input (in more special cases). Also, precision will be lost (but you are explicitly asking for this). Do this only if the formatting is really essential for some reason. (It might be possible to come up with a cleaner solution, but if this works for you, it probably isn't worth investing time into coding up a custom solution.) –  Szabolcs Mar 11 '12 at 12:14
show 1 more comment

1 Answer 1

I'm not understanding, or I can't reproduce the behaviour of the pasting of the first part, please post a more concrete example. As to the 0.3333 issue, you could set the NumberMarks option of the input cells to False. Also, if you really meant that you wanted it copied as 0.3333 when your output had been 0.333333 you should also change PrintPrecision to 4

To change the options, a way would be to go to Format-Edit stylesheet, write Input in the box and press enter. Then, select the cell, go to Format->Options inspector. Check that "Selection" is set, search for the mentioned options and edit them

After these changes, any machine precision number you type in an Input cell, once you append a "`" mark, will be displayed as a rounded number, without the "`", and with PrintPrecision digits. However, you won't be losing precision in your calculations

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.