Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.
Integrate[ ArcTan[x]/(1 + x) Log[(1 + x^2)/2], {x, -1, 1}]

I used Mathematica 9.0.1 on Windows7 32bit, Mathematica 9 cannot compute this, but Mathematica 8 gives Pi^3/96, is this a bug?

share|improve this question
    
I get the same result with Mathematica 9, but, admittedly, it took 3 times as long as with v8... –  sebhofer Jun 13 '13 at 8:32
    
I have to correct myself, I now (after quitting the kernel) get Infinity (as pointed out by Artes)... No clue what went wrong before. –  sebhofer Jun 13 '13 at 16:21
    
@explorer Couldn't Mathematica 9 really return any result or colud it return Infinity as I demonstrated in my answer? Have you tried to integrate TrigToExp@ArcTan[x] ? –  Artes Jun 16 '13 at 17:19

1 Answer 1

up vote 8 down vote accepted

This issue reminds many similar problems with Integrate. We have in Mathematica 8.0.4:

Integrate[ ArcTan[x]/(1 + x) Log[(1 + x^2)/2], {x, -1, 1}]
Pi^3/96

However in Mathematica 9.0.1 it takes quite a long time yielding a different result:

Integrate[ ArcTan[x]/(1 + x) Log[(1 + x^2)/2], {x, -1, 1}]
Infinity

This is a bug, we can compare it with the NIntegrate result which yields the number numerically the same as in ver. 8.

Of course the result should be the same if we substitute ArcTan by its equivalent:

TrigToExp[ ArcTan[x] ]
1/2 I Log[1 - I x] - 1/2 I Log[1 + I x]

but now the result is the same as in ver. 8:

Integrate[ TrigToExp[ ArcTan[x]]/(1 + x) Log[(1 + x^2)/2], {x, -1, 1}]
Pi^3/96
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.