Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I am plotting a graph which has about 196 nodes.

GraphPlot[{1 -> 24, 2 -> 24, 20 -> 364, 20 -> 779, 21 -> 130, ...
               378 -> 386, 492 -> 841, 779 -> 783, 839 -> 841}, 
     DirectedEdges -> False, VertexLabeling -> True, 
     Method -> "SpringElectricalEmbedding", 
     PackingMethod -> "ClosestPackingCenter"]

However when the output is produced it looks like below where many of the nodes are overlapping. How to tell Mathematica to produce a large picture so that no nodes overlap. True this might not be practical for very large graphs, but for 196 nodes, I would like no node to overlap another.

enter image description here

share|improve this question
    
What if you resize the picture in the front end? –  J. M. Jun 5 '13 at 18:59
    
Yes, that does reduce the problem greatly, but it seems I can resize it only a finite amount with my mouse. –  smilingbuddha Jun 5 '13 at 19:06
    
I was obliquely pointing out why you're seeing the crowdedness. Consider using tinier labels for your nodes. –  J. M. Jun 5 '13 at 19:12

2 Answers 2

up vote 1 down vote accepted

You can adjust the image size using the option ImageSize->600 or ImageSize->800, whatever is needed. You might have missed this option when you look at the help for GraphPlot because it is listed indirectly: when you open up the Details section says: GraphPlot has the same options as Graphics, and under Graphics is where you find the ImageSize option.

share|improve this answer
    
Thanks. Just what I was looking for! –  smilingbuddha Jun 5 '13 at 19:37

Use the Option ImageSize. If ImageSize->Large is not big enough, you can specify the magnification explicitly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.