Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

This question is an exact duplicate of:

When I put Antialiasing -> True in a BarChart3D, it doesn't work. Here is the code.

BarChart3D[{{1, 2, 3},{2,3,4}}, 
  ChartStyle -> None, 
  ChartLayout -> "Grid", 
  Ticks -> None, 
  Antialiasing -> True]

BarChart.png

How can I apply anti-aliasing to a BarChart3D?

share|improve this question

marked as duplicate by Mr.Wizard Aug 11 '13 at 9:18

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Is antialiasing enabled in Preferences? –  cormullion May 12 '13 at 8:12
    
@cormullion Sure:) I've also enabled AA in GPU setting(NVIDIA control panel, for me). –  user7409 May 12 '13 at 8:23
    
So it's a platform thing. With more details, perhaps others can help. –  cormullion May 12 '13 at 8:33
    
Yes, please add details (version, OS, video card, picture). –  Sjoerd C. de Vries May 12 '13 at 9:14
1  
@user7409 From the documentation, it looks like Antialiasing is a Style option, not a BarChart3D option, so you have to wrap the bar chart in a Style. –  amr May 12 '13 at 9:57
show 12 more comments

1 Answer 1

For what it's worth I believe the correct syntax is:

BarChart3D[{{1, 2, 3}, {2, 3, 4}}, ChartStyle -> None, ChartLayout -> "Grid", 
  Ticks -> None, BaseStyle -> Antialiasing -> True]

but as stated above your hardware must support it.

share|improve this answer
    
Won't work either. www1.picturepush.com/photo/a/12918114/1024/Anonymous/… –  user7409 May 12 '13 at 21:30
    
@user7409 do you have anti-aliasing in any 3D graphics inside Mathematica? –  Mr.Wizard May 12 '13 at 21:38
    
Sure. Everything's fine except BarChart3D. I've found that the axes are fine. www3.picturepush.com/photo/a/12918356/1024/Anonymous/… –  user7409 May 12 '13 at 22:31
    
@user7409 would you give me (in the question, because it won't fit in a comment) the output of Options[BarChart3D]? –  Mr.Wizard May 13 '13 at 3:40
    
Using V9.0.1 on OS X, I find BaseStyle -> Antialiasing -> True accomplishes nothing if the slider in Preferences > Appearance > Graphics is to the far left. Moving the slider sufficiently to the right adds anti-aliasing even if this option is not set. –  m_goldberg Aug 10 '13 at 22:28
show 3 more comments

Not the answer you're looking for? Browse other questions tagged or ask your own question.