Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

Since this morning I'm not able to launch Mathematica (vs. 8.0.4) on my Mac (OS 10.8.3). Every time I click on the icon Mathematica opens the "Messages" box without any messages. After some seconds my Mac is telling me that the program was unexpectedly closed.

It sounds wired and indeed feels this way because when I shut down my Mac last night Mathematica was running just fine. My license is still active as well. Does anyone have/had a similar problem. Any ideas are more than welcome. Thanks in advance.

share|improve this question
    
try launching it from commandline or try to launch the kernel only and write the output –  Misery Apr 3 '13 at 7:23
    
@Misery: it worked! However, I closed the window by accident and now does not anymore. I'll try to install it again. –  chris Apr 3 '13 at 7:41
    
@chris This is a very specific question which will most probably closed of being too localized. You can always come to chat and ask with such questions. –  halirutan Apr 3 '13 at 7:42
    
You could try a safe boot... –  cormullion Apr 3 '13 at 8:21
    
Also $ rm -rf ~/Library/Saved\ Application\ State/com.wolfram.Mathematica.savedState/, it worked for me thanks to acl :) –  hhh Apr 18 '13 at 17:26
add comment

closed as too localized by Sjoerd C. de Vries, whuber, Oleksandr R., Artes, rm -rf Apr 3 '13 at 22:19

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

This answer is not mine but halirutan's who helped me in the chat.

First, find the folder with files named "MathKernel" and "Mathematica" via the terminal. The appropriate command is cd Applications/Mathematica.app/Contents/MacOS/. Or the equivalent path on your machine.

Second, start a clean Mathematica session via ./Mathematica -clean. I'm not sure exactly what it does but it seems to open Mathematica with "clean" preferences.

Now Mathematica should work as usual.

share|improve this answer
    
This did not work for me but "$ rm -rf ~/Library/Saved\ Application\ State/com.wolfram.Mathematica.savedState/" worked. –  hhh Apr 18 '13 at 17:31
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.