Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I have a function that creates a 2D line with filling to the axis. When I copy this graphic into word it is very fuzzy, so much so that the numbers and text are almost unreadable, not to mention the aesthetic problem.

When I take away the filling, the graphic can be copy and pasted into word as normal.

the code used is:

Show[
  Plot[d[x], {x, 0, 5}, PlotRange -> {-0.003, 0.003}], 
  ListLinePlot[residualsdata, PlotStyle -> Black, Filling -> Axis, 
    FillingStyle -> Directive[Opacity[0.5], Green]]]

The graphic without the filling is gotten by:

Show[
  Plot[d[x], {x, 0, 5}, PlotRange -> {-0.003, 0.003}], 
  ListLinePlot[residualsdata, PlotStyle -> Black]]

Does anybody know the cause of this problem and/or how to fix it?

share|improve this question
1  
Is this Word 2010? You might need to convert the picture to a drawing object - right click on the fuzzy picture, select Edit Picture, then Yes. –  Simon Woods Mar 6 '13 at 11:56
    
It would also help if we knew what d[x] was. –  m_goldberg Mar 6 '13 at 13:15
5  
The most likely cause is that the default copy format (EMF?) doesn't support transparency and therefore as soon as you add the filling, Mathematica will copy in a different format (likely bitmap). You ca experiment with Edit -> Copy As ad choose different formats and see which one gives good results. However, for the best possible result in Word, I'd recommend exporting to PNG using the Export command and a high ImageResoltuion setting. –  Szabolcs Mar 6 '13 at 13:19
    
Well, for LaTeX PDF/EPS are likely yo give better quality ... except for 3D graphics. –  Szabolcs Mar 6 '13 at 16:42
    
Related MathGroups thread: "Mathematica 8 Windows EMF/WMF export with transparent background?" –  Alexey Popkov Jan 10 at 2:33
add comment

2 Answers

The most likely cause is that the default copy format (EMF?) doesn't support transparency and therefore as soon as you add the filling, Mathematica will copy in a different format (likely bitmap). You ca experiment with Edit -> Copy As and choose different formats and see which one gives good results. However, for the best possible result in Word, I'd recommend exporting to PNG using the Export command and a high ImageResolution setting.

share|improve this answer
add comment

An alternative to rasterization suggested by Szabolcs is to insert in the Word document not a metafile (which you do by default by selecting graphics in the FrontEnd, copying and pasting it in MS Word) but an EPS vector image with flattened vector transparency and Mathematica fonts embedded in it (it has additional advantage of independence from Mathematica fonts). It is slightly more difficult because Mathematica's EPS export is rudimentary and you will need to Export your graphics to PDF first, then use Adobe software to flatten transparency and create EPS level 2 file from the exported PDF. But it is worth the effort because this way allows you to achieve the best possible vector quality for printing purposes. Here I discuss how to do it using Adobe Illustrator or Adobe Acrobat.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.