Mathematica Stack Exchange is a question and answer site for users of Mathematica. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Mathematica 7 and 8 installed on my laptop. Mathematica 7 starts quite fast, but Mathematica 8 is extremely slow to start. In the Option Inspector I canceled the "welcome screen" option at startup, and I tried canceling "opening a new notebook" at startup so that only the front end opens without any blank notebook, but as soon as I open a notebook, the whole front end freezes for about half a minute before opening it. As I said I do not experience this problem with M7. In this forum I have already found something related to my problem here but it doesn't answer it. I ran the command shown there which shows the time M8 spends to start and I got the following output :

 {"Initializing kernel connections..." -> 0.265},
 {"Initializing cell styles..." -> 0.764},
 {"Initializing fonts..." -> 1.076},
 {"Initializing menus..." -> 1.108},
 {"Initializing defaults notebook..." -> 1.654},
 {"Initializing defaults clipboards..." -> 2.278},
 {"Initializing internal preferences..." -> 2.418},
 {"Initializing kernels..." -> 3.619},
 {"Opening Welcome Screen..." -> 12.059},
 {"Closing Splash Screen..." -> 12.09},
 {"Preloading Favorites..." -> 12.137},
 {"Handling CommandLineOptions..." -> 12.137},
 {"Opening Files..." -> 12.137},
 {"Do Startup Action..." -> 12.137},
 {"Finished" -> 12.137}

and as you can see it seems that most of the time is spent on opening the splash screen just to close it 20 ms later !!!!!!! Do you guys have any idea how to overcome this.

I have asked support for this but ... well ... extremely poor assistance. So I am asking here. Thank you in advance :)

share|improve this question

closed as off-topic by Louis, MarcoB, m_goldberg, Yves Klett, Öskå Jun 29 at 16:59

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "The question is out of scope for this site. The answer to this question requires either advice from Wolfram support or the services of a professional consultant." – Louis, MarcoB, m_goldberg, Yves Klett, Öskå
If this question can be reworded to fit the rules in the help center, please edit the question.

I have tried resetting everything to factory configuration but did not help. – NBM Jan 28 '13 at 17:27
Have you tried starting Mathematica from the command-line with the -noSplashScreen option? See Details in the link. – halirutan Jan 28 '13 at 17:47
This should anyway only suppress the splash screen which is the Mathematica star. What takes time seems to be the welcome screen. I havent read your question carefully enough. – halirutan Jan 28 '13 at 18:02
Yves has a good point. Are you using a license server or an activation key and password? You can find out by looking at the %appdata%\Mathematica\Licensing\mathpass file. If it has an entry that starts with a ! sign and a server address, then your computer needs to connect to a license server. Also, is kernel startup slow as well? (Start MathKernel.exe on it own) – Szabolcs Jan 28 '13 at 18:45
I'd say unlikely, but you can go to Preferences -> Internet Connectivity, and forbid it to connect to the internet for any purpose. This'll effectively disable that too. – Szabolcs Jan 28 '13 at 20:08