Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I hate small integral signs and thus I like ScriptLevel to be 0. I have set ScriptLevel to be 0 for Text cells, DisplayFormula, and InlineFormula. When in a text cell I press ctrl+( to create an inline math mode cell (for lack of better term). When I do this I notice in the option inspector that ScriptLevel is 1 and this causes a small integral sign to be typed.

In Mathematica 8 this did not happen. It was ScriptLevel 0. In Mathematica 9 is 1 and I haven't been able to figure how to change it to be 0 by default. I've noticed a number of odd behaviors changed in the new Default.nb and this seems to be one of them. I'm using OS X 10.7.2.

When using my notebooks created under Mathematica 8 I get the correct behavior. But not when using new notebooks created in Mathematica 9.

share|improve this question
    
The inline math mode using Ctrl-( is typeset using the TraditionalForm style. You can try setting ScriptLevel to 0 for that. I can't test right now –  rm -rf Jan 9 '13 at 20:28
    
In additional to @Hypnotoad suggestion you can also use the V8 default stylesheet from within V9. –  Mike Honeychurch Jan 9 '13 at 20:33
    
@MikeHoneychurch I'll try that. I don't see where TraditionalForm is defined in the default stylesheet. I have set DefaultNewInlineCellStyle for my Text cells to be "DisplayFormula" and have set ScriptLevel to 0 for "DisplayFormula". –  YequalsX Jan 9 '13 at 20:35
    
@YequalsX don't edit the default stylesheet. Edit your private notebook stylesheet. Format>>Edit Stylesheet ... If you are unsure about how to do this search this site with key word(s) "stylesheet". In fact I remember answer a question that is related: had to change an option in TraditionalForm. Let me find it ... –  Mike Honeychurch Jan 9 '13 at 20:38
    
@YequalsX i literally have to leave this minute but the post I am thinking of concerned a user that had unwanted background color for his tick labels so had to change TraditionalForm in his stylesheet. –  Mike Honeychurch Jan 9 '13 at 20:44

1 Answer 1

up vote 4 down vote accepted

It works on my Mathematica 9 by the following steps:

  • Find the system stylesheet Core.nb

  • Copy the "InlineCell" style from Core.nb into our own stylesheet

  • Change value of ScriptLevel option in "InlineCell" style to 0

share|improve this answer
    
Thank you for this information. I did not know Core.nb had these definitions. –  YequalsX Jan 9 '13 at 22:12
    
@YequalsX You are welcome :) This method should work for version 8 too. Usually I copy some styles from core.nb to my own stylesheet for some more customizing. –  Silvia Jan 9 '13 at 22:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.