Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I am trying to use assumptions to simplify an integral, but I can't seem to get the assumptions to apply themselves. Here is the code I am using:

my code

Note the expressions in the assumption can be found in the answer.

Am I doing something wrong? Is there a proper way of using assumptions? I read through the Mathematica tutorial for assumptions but that seems to have confused me more.

share|improve this question
2  
Could you please include yor code in the answer - with all preliminary function and variable defenitions. –  Vitaliy Kaurov Dec 4 '12 at 4:57
    
Apsrt from the tutorial on Assumptions you probably should also read its dedicated documentation page. There, under the heading "More information" (v8) or "Details" (v9) you can find: "The assumptions can be equations, inequalities, or domain specifications, or lists or logical combinations of these." So: no Rules –  Sjoerd C. de Vries Dec 4 '12 at 8:00
add comment

1 Answer 1

up vote 6 down vote accepted

Assumptions need to be quantified equations or inequalities, so replace your rules with equations. I'm guessing Integrate probably won't do too much with these, either, so attempt to use FullSimplify on the results with your new assumptions.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.