Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I installed Mathematica 9 on my Windows 7 system (installed the font patch afterwards so the BSOD are gone) but the "Extras" package installation fails claiming it can't de-install the Mathematica 8 packages.

I de-installed Mathematica 8 and tried re-installing Mathematica 9 again but it keeps claiming the Mathematica 8 add-ons can't be removed. At the end CDF (amongst other stuff?) is not working in the browser.

Any thoughts?

share|improve this question
    
Hi @Nasser, No I mean the add-on during the standard install. I also believe that they're labeled extra packages but I'm not sure. It's the part where CDF browser plugins get installed. –  Lou Dec 3 '12 at 14:16
    
For Mac: when opened, the Mathematica 9 .dmg image includes the installer includes a separate item "extra packages" –  murray Dec 3 '12 at 15:47
    
(I didn't edit soon enough my preceding comment to complete it. Here it is:) For Mac: when opened, the Mathematica 9 .dmg image includes, alongside Mathematica.app itself, an `Extras.pkg" for installing the browser plug-in and indexing add-on. For Windows, and this was for Mathematica 8, after you ran the installer for Mathematica itself, you were then prompted whether to install the extras. –  murray Dec 3 '12 at 15:57
add comment

1 Answer

up vote 0 down vote accepted

I fixed the problem by de-installing Mathematica 9. Then I re-installed Mathematica 8 which gave an error message about the deinstall msg fle not being present. However the installation continued. Then I de-installed the extra package through the control panel (with windows) first and then de-installed Mathematica 8. After that I removed all directories described at http://support.wolfram.com/kb/4730 Then I reinstalled Mathematica 9 (with the latest package). No more errors! However the CDF browser plugin is only installed for Chrome. No idea why because IE is my default browser. I suppose I can install the plug-in for IE from the Wolfram site but I'm doubting if it's not better to wait a bit.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.