Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I am editing an expression containing wide fractions (typeset with fraction boxes):

Nicely typeset equation

But if, while editing the equation, the fraction exceeds some threshold (seems to be approximately the window width), the front-end will helpfully replace my nicely-typeset fraction box

$$\frac{\text{numerator numerator numerator}}{\text{denominator denominator denominator}}$$

with (numerator numerator numerator)/(denominator denominator denominator) (on one line, with parentheses added). This also happens if you write the equation correctly, and then resize the window to be narrower than the fraction (even if the cursor isn't in that cell!)

RUINED

The automatic reformatting persists after resizing the window back:

RUINED FOREVER

The result is an unreadable jumble.

This is a serious problem for anyone using a tiling window manager.

The same issue occurs with wide expressions inside of square-root signs.

Is it possible to disable this behavior?

share|improve this question

2 Answers 2

up vote 4 down vote accepted

Try setting the option FractionBoxOptions, suboption MultilineFunction to None for the style, or globally.

share|improve this answer
2  
    
Nice contribution @Mechanicalsnail –  Rojo Nov 22 '12 at 7:29

You can always use ctrl+shift+T to force the cell displayed as TraditionalForm, or ctrl+shift+I to InputForm, or ctrl+shift+N to StandardForm

share|improve this answer
2  
What does this have to do with the question? –  Mechanical snail Nov 22 '12 at 7:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.