Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I understand how (in theory) to get images to be a specific size in inches, but when I follow the documentation, all of my output seems to be scaled down by a factor of a bit less than 70% (e.g., ImageSize -> 72x8 gives an image size of about 5.5 inches rather than 8).

How do I ensure that my images print at a specified size in inches? Are there settings or additional options beyond those described in the documentation for ImageSize that I need to use?


In context, what I'm trying to do is print a generated graphic from within a Manipulate using a button using

Button["Print",  NotebookPrint[pat]]

or perhaps something like

Button["Print", NotebookPrint[Show[pat, ImageSize -> 72 patzise]]]

and I'd ideally like to apply whatever settings are needed to get a properly sized output, without messing with global or notebook level settings.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Try setting the printing environment on 'Working' using the File > Printing Settings > Printing Environment menu. The default for printing, the Printout stylesheet uses a condensed version of the screen stylesheet.

Proof:

If you open the stylesheet editor (Format > Edit Stylesheet...) while using the standard notebook style you get this:

Mathematica graphics

Click on Default.nb and open the environment style to find the Printout style:

Mathematica graphics

Open the Printout cell with CtrlShiftE to find:

Cell[StyleData[All, "Printout"], Magnification -> 0.72]
share|improve this answer
1  
Related: stackoverflow.com/a/6124065/590388 –  Alexey Popkov Oct 29 '12 at 23:14
    
That works in some cases (e.g. using the context menu) but not others, in particular not for NotebookPrint[g], which is what I'm doing. I've tried Button["Print", {SetOptions[pat, PrintingStyleEnvironment -> "Working"], NotebookPrint[pat]}] (I need to use a button to print), but that doesn't work. –  raxacoricofallapatorius Oct 29 '12 at 23:15
    
So what I need to do in context is set just the PrintingStyleEnvironment for the expression I'm printing (as in the comment above), as I print, but ideally leave global settings unchanged. –  raxacoricofallapatorius Oct 29 '12 at 23:42
    
I've updated the question to that effect. –  raxacoricofallapatorius Oct 30 '12 at 4:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.