Mathematica Stack Exchange is a question and answer site for users of Mathematica. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have some very old Mathematica notebooks file (.m) files from Version 2. When I try to open them using Mathematica 8.0 (on a Linux system) Mathematica instantly shuts down (no error message - just closes). However they open and format correctly using WolframCDFPlayer. I can copy from the player but not as cell expressions so a lot of hand editing is required to split and format the cells in the new notebook.

Is there any, perhaps undocumented, way to read or import these files into the current version of Mathematica that would retain some degree of the original formatting?

share|improve this question
If at all possible please upload one of these files for us to experiment with. – Mr.Wizard Oct 22 '12 at 15:15
You mean *.ma files, right? I'm using 8.0.4 on Fedora 17, and Mathematica does the conversion. It doesn't automatically open the converted notebooks, however; you have to go back and open the converted notebooks yourself. – J. M. Oct 22 '12 at 15:23
@J.M. It is not a *.ma file. It is (named as) an *.m file. The top of the file contains a lot of font info. Then :[font = title; inactive; Cclosed; dontPreserveAspect; startGroup; ] Elliptic Curve Calculator :[font = subsubtitle; inactive; dontPreserveAspect; ] Version 2.0 .. – Ron Burns Oct 22 '12 at 16:21
@Mr.Wizard How do I upload a file? – Ron Burns Oct 22 '12 at 16:23
Two things to try. First, see if renaming it to .ma works around the problem. Second, check to see if you're running 8.0.4. You say that CDF Player fixed it...but CDF Player and the Mathematica FE are basically the same program. However, you may have been running different versions, and maybe your version of Player is more recent. – John Fultz Oct 23 '12 at 2:35

The CDF reader solved the problem.

Opening the file with the CDF player does the conversion and writes a *.nb which then reads properly into Mathematica. Trying to open the file with Mathematica did not open nor write a converted file.

(Example *.m files from The Mathematica Journal Vol 1 illustrate the problem)

Thank you for the hints which led me look a bit deeper.

share|improve this answer
You might want to choose to accept your own answer, as you seem to have figured this out on your own. Just a suggestion. :) – telefunkenvf14 Jan 2 '13 at 21:13

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.