Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

This is certainly a newbie question but I could not find the answer by searching.

I am using Mathematica 8 under Windows 7. I want to use default magnification of 150% for all notebooks and help files which I open in Mathematica. At present I have to do it through Windows->Magnification for every single document I open which is of course tedious. I assume there is a way of setting some options which is saved across different sessions as well.

Would appreciate any help.

share|improve this question
    
Related: Fontsize is too small –  Mr.Wizard Jul 11 at 17:45
add comment

3 Answers 3

up vote 12 down vote accepted

If the reason you ask is because the fonts are much too small, then there is another approach that is arguably more correct than changing Magnification, and that is to specify a better screen resolution. By default it is 72ppi, but screens haven't been like that for years (mine is about 100ppi).

SetOptions[$FrontEndSession, 
 FontProperties -> {"ScreenResolution" -> 96}
]

If you like the setting and what to make it persist between sessions, replace $FrontEndSession with $FrontEnd.

share|improve this answer
1  
You can also set this to Automatic, or alternatively set it from the options inspector. I'd love to know what it actually does, though... I set mine to 72 and to 135 to see the difference, and nothing seemed to happen. –  acl Feb 4 '12 at 21:10
1  
@acl on Windows 7 it makes a huge difference; the fonts scale proportionately. It would be worth a new question why this doesn't work on your system. –  Mr.Wizard Feb 4 '12 at 21:20
    
I am not sure it doesn't: Heike pointed this out some time ago (in some other answer), and I recall it did make a difference. I'll try to work out what is going on. –  acl Feb 4 '12 at 21:30
    
@acl perhaps my SetOptions form is not system-independent? –  Mr.Wizard Feb 5 '12 at 0:31
1  
The disadvantage is that images won't be shown pixel-to-pixel when at 100% magnification. I.e. while the solution you describe should be smarter than a simple magnification change, unfortunately it is not. I wish I could find a solution which leaves Images alone. –  Szabolcs Feb 5 '12 at 14:29
show 6 more comments

Here are step by step instructions:

  1. Open the menu item Format -> Options Inspector...

  2. Set "Show option values" to "Global Preferences"

  3. Find Notebook Options -> Display Options

  4. Set Magnification to 1.5

Now all your notebooks will show at 150% magnification.

share|improve this answer
    
Many thanks, works like a charm. –  Mikael Anderson Feb 4 '12 at 18:03
    
@Szabolcs When I do the above procedure, it affects magnification on all existing notebooks, but new notebooks still open at 100%, not at 1.25 (which is what I set this option to). Am I missing something? –  rogerl Jul 3 '12 at 13:44
    
@rogerl Does it show 100% in the status bar or is it actually 100%? It seems it does show 100%, but the base magnification is actually higher, even in newly opened notebooks. (As you can see from the text size.) –  Szabolcs Jul 3 '12 at 14:26
    
@Szabolcs Yeah, the base magnification is higher. A little odd and confusing. Thanks. –  rogerl Jul 12 '12 at 12:26
    
Note: If your Notebook (or maybe cell, graphics, plot) defines ScreenResolution, this will override the Global Preference, so you will see no effect. See my answer. –  NoEscape Oct 18 '12 at 6:17
show 1 more comment

The better option may be setting "ScreenResolution" on a per notebook basis. This way you do not change the appearance of the palettes, help browser, etc.

Try

SetOptions[SelectedNotebook[], 
 FontProperties -> {"ScreenResolution" -> Automatic}
]

instead of Automatic you can put in a number. Try moving from 72 upward. 96 is a good value for todays systems/screens. Automatic results in 96 on my system. If the Times font is still too small for you, try 108 or more.

Of course you can set the corresponding value via the Option Inspector (Formatting Options - Font Options - FontProperties - ScreenResolution). Just remember choosing "Selected Notebook" in the first listbox.

share|improve this answer
    
Note: Magnification can be safely set on a global base. See Szabolcs' post. If you want to enlarge ALL Palettes and the Help Browser, set global Magnification first, then adjust your ScreenResolution per notebook! –  NoEscape Oct 17 '12 at 13:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.