Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

In Mathematica 8.0.4 under Mac OS X 10.8.2, when I evaluate

Needs["OpenCLLink`"]

I get error General::cdir: Cannot set current directory to authserver.

Where should that directory be?

share|improve this question
    
First: it works for me (MMA 8.0.4.0 on 10.8.2, recent MacBook Pro). Second: I had the same problem with CUDALink some time ago, and it actually happened as a byproduct of CUDA actually not being supported on my hardware. And, the error was non fatal, i.e. the CUDALink package was actually loaded even though I had the error. So, I suppose my advise is two-fold: 1. Are you sure it matters? 2. After you run this command, what is the output of OpenCLGQ[]? –  F'x Sep 21 '12 at 12:24
    
The result of OpenCLQ[] (not OpenCLGQ[]) is True. And, in fact, OpenCL does seem to be working. Guess I'll report the possibly spurious error message to Wolfram tech support. Thanks, @F'x. –  murray Sep 21 '12 at 16:30

1 Answer 1

Current status on this is that the error can be seen somewhat randomly on OpenCLLink and CUDALink packages on Mac OS MMA 8.0.4.0. The package appears to be correctly loaded despite the error.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.