Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I am trying to produce a polar plot. The axis should be in degrees. While no error occurs, the pdf export isn't working properly. Instead of the degree symbol I get a square (while using acrobat) and a 'D' when I use nitro. The code I am using is

r = 2.81794*10^(-15);
m = 511;
a1 = 1/m;
a2 = 5.9/m;
ds1[theta_] := 
 10*r^2*(1/(1 + a1*(1 - Cos[theta])))*((1 + Cos[theta]*Cos[theta])/
  2)*(1 + (a1^2*(1 - Cos[theta])^2)/((1 + 
     Cos[theta]*Cos[theta])*(1 + a1*(1 - Cos[theta]))))
ds2[theta_] := 
 10*r^2*(1/(1 + a2*(1 - Cos[theta])))*((1 + Cos[theta]*Cos[theta])/
2)*(1 + (a2^2*(1 - Cos[theta])^2)/((1 + 
     Cos[theta]*Cos[theta])*(1 + a2*(1 - Cos[theta]))))

Needs["PlotLegends`"]
PolarPlot[{ds1[theta], ds2[theta]}, {theta, -π, π}, PolarAxes -> True, 
  PolarGridLines -> True, PolarTicks -> {"Degrees", Automatic}, 
  PlotRange -> Automatic, 
  PlotLabel -> 
  Style[Framed["Klein-Nishina Compton Cross Section"], 20, Red, 
   Background -> Lighter[Yellow]], 
   PlotLegend -> {"1keV", "5.9keV"}, LegendShadow -> {.01, -.01}, LegendTextSpace -> 5, 
  LegendBackground -> LightPurple, LegendSize -> {0.5, 0.5}, 
   Background -> LightYellow] 

 Export["Klein.pdf", %]

Mathematica graphics

I also tried to export it in other formats, which is working fine, however I need .pdf format...

share|improve this question
1  
Welcome to the site! Please try to post a Minimal working example that displays the behavior you want to show. –  belisarius Sep 17 '12 at 16:21
    
Thank you for your warm welcome. You are propably true; that wasn't a minimum...I'll edit the question! –  Thanos Sep 17 '12 at 16:23
    
@Thanos I get a degree symbol correctly when I export to PDF (Mac OSX 10.8, MMA 8.0.4). It could be because some fonts are missing on your system... –  rm -rf Sep 17 '12 at 16:24
    
@Thanos I also get a degree symbol when I export to PDF (Win 7 MMA 8.0.4). –  David Slater Sep 17 '12 at 16:26
1  
Try to add this option at the end of your PolarPlot: BaseStyle -> {FontFamily -> "Helvetica"} or any other font that is installed on your computer. –  VLC Sep 17 '12 at 16:56

1 Answer 1

Force use of system fonts by the following:

SetOptions[EvaluationNotebook[], 
 PrivateFontOptions -> {"OperatorSubstitution" -> False}]

or

SetOptions[$FrontEnd, 
 PrivateFontOptions -> {"OperatorSubstitution" -> False}]

Note: Options set for $FrontEnd are by default stored in the front end init.m file, and are persistent between front end sessions. (ref. $FrontEnd)

Failing that try another PDF creator.

share|improve this answer
    
I tried both ways but unfortunately it didn't work... I tried again with nitro reader and adobe acrobat reader nut the issue remains... I also tried with Ocular and Ubuntu's Document Viewer but again no degree symbol... –  Thanos Sep 19 '12 at 8:53
    
What OS and version of Mathematica are you using? –  Chris Degnen Sep 19 '12 at 9:01
    
I am running Mathematica 8.0.0 in Windows Vista. –  Thanos Sep 19 '12 at 9:08
    
I also tried in FoxIt but again nothing happened... –  Thanos Sep 20 '12 at 6:38
    
How about CutePDF. Install, then File -> Print, select Printer Name: CutePDF Writer. Very reliable. cutepdf.com/products/cutepdf/writer.asp –  Chris Degnen Sep 20 '12 at 8:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.