Take the 2-minute tour ×
Mathematica Stack Exchange is a question and answer site for users of Mathematica. It's 100% free, no registration required.

I currently use the Windows IME on Windows Vista to allow myself to type Chinese characters (not in Mathematica), and by default typing CtrlSpace switches between the English keyboard and the Chinese keyboard. When in Mathematica, I would like to use the default shortcut CtrlSpace to move out of subscripts and superscripts.

Is it possible to retain the functionality of this keyboard shortcut in Mathematica? I cannot figure out how to remove the shortcut from the IME, which is an acceptable solution, since i do not use this shortcut to switch languages.

share|improve this question
1  
I end up not using this shortcut in MMA. Totally give up LOL –  Silvia Feb 26 '13 at 7:28
add comment

2 Answers

up vote 2 down vote accepted

The MS interface for modifying the key strokes is buggy and does not correctly read and write the registry keys where the input method is held. Try removing the shortcut and press [Apply] to see this in action. The keyboard shortcuts CTRL+SPACE are only on the two Chinese languages by default. There are guides online for how to edit the registry keys directly to fix this specific issue. I guess it's a bonus feature!

share|improve this answer
    
After doing further research, I confirmed that (at least for my windows version) you are correct. I changed the registry key on my work computer and the fixed worked. I am still trying to get it to work on my laptop, which I assume is giving me trouble due to a different version of Windows (7 versus Vista). –  Carl Morris Nov 21 '13 at 17:12
add comment

It seems your Windows system works differently than mine (Win7-64). I don't believe I can use the Ctrl-Space combo, but I know how to change the setting:

Right click on the language symbol in the task bar

Select Settings from the pop-up menu, in the resulting dialog box pick the 3rd tab

Mathematica graphics

Select the action by clicking on a keyboard name, and pressing the "Change Key Sequence" button. You get either this

Mathematica graphics

or this

Mathematica graphics

dialog box where you can select the key sequence you want or deselect it, as it seems that that is what you want.

share|improve this answer
1  
Your answer seems to give me exactly what I want, but for some reason I cannot disable the key sequence. I also tried changing the shortcut to another key binding that I do not use, but the ctrl+space combination remains active. I do not want this to become further off topic from Mathematica so I will accept this answer and ask on another forum. –  Carl Morris Aug 30 '12 at 2:01
    
@Carl Actually on Windows cycling through input languages (Left Alt Shift by default) is a separate function from switching between a Chinese and a non-Chinese language (Ctrl Space by default). That's why this didn't work. –  Szabolcs Nov 20 '13 at 12:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.